Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 1 | FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:" |
Brad Bishop | f61a81a | 2019-02-04 14:28:33 -0500 | [diff] [blame] | 2 | |
| 3 | SRC_URI += " file://pam.d/common-password \ |
| 4 | file://pam.d/common-account \ |
| 5 | file://pam.d/common-auth \ |
Richard Marian Thomaiyar | 2b59705 | 2019-11-02 21:24:29 +0530 | [diff] [blame] | 6 | file://pam.d/common-session \ |
Brad Bishop | f61a81a | 2019-02-04 14:28:33 -0500 | [diff] [blame] | 7 | " |
| 8 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 9 | do_install:append() { |
Matt Spinler | 31ab8e7 | 2018-10-16 11:32:13 -0500 | [diff] [blame] | 10 | # The libpam recipe will always add a pam_systemd.so line to |
| 11 | # common-session if systemd is enabled; however systemd only |
| 12 | # builds pam_systemd.so if logind is enabled, and we disable |
| 13 | # that package. So, remove the pam_systemd.so line here. |
| 14 | sed -i '/pam_systemd.so/d' ${D}${sysconfdir}/pam.d/common-session |
| 15 | } |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame^] | 16 | |
| 17 | RDEPENDS:${PN}-runtime += "${MLPREFIX}pam-plugin-cracklib-${libpam_suffix} \ |
| 18 | ${MLPREFIX}pam-plugin-tally2-${libpam_suffix} \ |
| 19 | ${MLPREFIX}pam-plugin-pwhistory-${libpam_suffix} \ |
| 20 | ${MLPREFIX}pam-plugin-succeed-if-${libpam_suffix} \ |
| 21 | ${MLPREFIX}pam-plugin-localuser-${libpam_suffix} \ |
| 22 | " |