blob: 9e35c7ba5b99cad7544f6dd2184cf1bf98a7d87f [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "An adapter to Linux kernel support for inotify directory-watching."
Andrew Geissler517393d2023-01-13 08:55:19 -06002HOMEPAGE = "https://pypi.org/project/inotify/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://setup.py;md5=79b7ec72aa0d446a552d3cceb5799e41;beginline=28;endline=28"
5
6SRC_URI[sha256sum] = "974a623a338482b62e16d4eb705fb863ed33ec178680fc3e96ccdf0df6c02a07"
7
8SRC_URI = " \
9 git://github.com/dsoprea/pyinotify.git;branch=master;protocol=https \
10 file://run-ptest \
11"
12
13SRCREV = "9be6a51d1660991562eefaaddefa757ca0e0e00f"
14
15S = "${WORKDIR}/git"
16
17inherit setuptools3 ptest
18PIP_INSTALL_PACKAGE = "inotify"
19PIP_INSTALL_DIST_PATH = "${S}/dist"
20
21
22RDEPENDS:${PN} += " \
23 python3-ctypes \
24 python3-logging \
25"
26
27RDEPENDS:${PN}-ptest += " \
28 ${PYTHON_PN}-pytest \
29"
30
31do_install_ptest() {
32 install -d ${D}${PTEST_PATH}/tests
33 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
34}