Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "Stream EDitor (text filtering utility)" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/sed/" |
| 3 | LICENSE = "GPLv2+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 5 | file://sed/sed.h;beginline=1;endline=17;md5=e00ffd1837f298439a214fd197f6a407" |
| 6 | SECTION = "console/utils" |
| 7 | PR = "r7" |
| 8 | |
| 9 | SRC_URI = "${GNU_MIRROR}/sed/sed-${PV}.tar.gz \ |
| 10 | file://fix_return_type.patch \ |
| 11 | file://sed-4.1.2_fix_for_automake-1.12.patch \ |
| 12 | file://Makevars" |
| 13 | |
| 14 | SRC_URI[md5sum] = "928f0e06422f414091917401f1a834d0" |
| 15 | SRC_URI[sha256sum] = "638e837ba765d5da0a30c98b57c2953cecea96827882f594612acace93ceeeab" |
| 16 | |
| 17 | inherit autotools texinfo update-alternatives gettext |
| 18 | |
| 19 | do_configure_prepend () { |
| 20 | cp ${WORKDIR}/Makevars ${S}/po/ |
| 21 | } |
| 22 | |
| 23 | do_install () { |
| 24 | autotools_do_install |
| 25 | install -d ${D}${base_bindir} |
| 26 | if [ ! ${D}${bindir} -ef ${D}${base_bindir} ]; then |
| 27 | mv ${D}${bindir}/sed ${D}${base_bindir}/sed |
| 28 | rmdir ${D}${bindir}/ |
| 29 | fi |
| 30 | } |
| 31 | |
| 32 | ALTERNATIVE_${PN} = "sed" |
| 33 | ALTERNATIVE_LINK_NAME[sed] = "${base_bindir}/sed" |
| 34 | ALTERNATIVE_PRIORITY = "100" |
| 35 | |