Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Gstreamer1.0 package groups" |
| 2 | LICENSE = "MIT" |
| 3 | |
| 4 | inherit packagegroup |
| 5 | |
| 6 | COMMERCIAL_PLUGINS = "${COMMERCIAL_AUDIO_PLUGINS} ${COMMERCIAL_VIDEO_PLUGINS}" |
| 7 | DEPENDS_UGLY="${@'gstreamer1.0-plugins-ugly' if 'ugly' in COMMERCIAL_PLUGINS.split('-') else ''}" |
| 8 | DEPENDS_BAD="${@'gstreamer1.0-plugins-bad' if 'bad' in COMMERCIAL_PLUGINS.split('-') else ''}" |
| 9 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-good ${DEPENDS_UGLY} ${DEPENDS_BAD}" |
| 10 | |
| 11 | PACKAGES = "\ |
| 12 | gstreamer1.0-meta-base \ |
| 13 | gstreamer1.0-meta-x11-base \ |
| 14 | gstreamer1.0-meta-audio \ |
| 15 | gstreamer1.0-meta-debug \ |
| 16 | gstreamer1.0-meta-video" |
| 17 | |
| 18 | ALLOW_EMPTY_gstreamer1.0-meta-base = "1" |
| 19 | ALLOW_EMPTY_gstreamer1.0-meta-x11-base = "1" |
| 20 | ALLOW_EMPTY_gstreamer1.0-meta-audio = "1" |
| 21 | ALLOW_EMPTY_gstreamer1.0-meta-debug = "1" |
| 22 | ALLOW_EMPTY_gstreamer1.0-meta-video = "1" |
| 23 | |
| 24 | RDEPENDS_gstreamer1.0-meta-base = "\ |
| 25 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gstreamer1.0-meta-x11-base', '', d)} \ |
| 26 | gstreamer1.0 \ |
| 27 | gstreamer1.0-plugins-base-playback \ |
| 28 | gstreamer1.0-plugins-base-gio \ |
| 29 | gstreamer1.0-plugins-base-alsa \ |
| 30 | gstreamer1.0-plugins-base-volume \ |
| 31 | gstreamer1.0-plugins-base-audioconvert \ |
| 32 | gstreamer1.0-plugins-base-audioresample \ |
| 33 | gstreamer1.0-plugins-base-typefindfunctions \ |
| 34 | gstreamer1.0-plugins-base-videoscale \ |
| 35 | gstreamer1.0-plugins-base-videoconvert \ |
| 36 | gstreamer1.0-plugins-good-autodetect \ |
| 37 | gstreamer1.0-plugins-good-souphttpsrc" |
| 38 | |
| 39 | RRECOMMENDS_gstreamer1.0-meta-x11-base = "\ |
| 40 | gstreamer1.0-plugins-base-ximagesink \ |
| 41 | gstreamer1.0-plugins-base-xvimagesink" |
| 42 | |
| 43 | RDEPENDS_gstreamer1.0-meta-audio = "\ |
| 44 | gstreamer1.0-meta-base \ |
| 45 | gstreamer1.0-plugins-base-vorbis \ |
| 46 | gstreamer1.0-plugins-base-ogg \ |
| 47 | gstreamer1.0-plugins-good-wavparse \ |
| 48 | gstreamer1.0-plugins-good-flac \ |
| 49 | ${COMMERCIAL_AUDIO_PLUGINS}" |
| 50 | |
| 51 | RDEPENDS_gstreamer1.0-meta-debug = "\ |
| 52 | gstreamer1.0-meta-base \ |
| 53 | gstreamer1.0-plugins-good-debug \ |
| 54 | gstreamer1.0-plugins-base-audiotestsrc \ |
| 55 | gstreamer1.0-plugins-base-videotestsrc" |
| 56 | |
| 57 | RDEPENDS_gstreamer1.0-meta-video = "\ |
| 58 | gstreamer1.0-meta-base \ |
| 59 | gstreamer1.0-plugins-good-avi \ |
| 60 | gstreamer1.0-plugins-good-matroska \ |
| 61 | gstreamer1.0-plugins-base-theora \ |
| 62 | ${COMMERCIAL_VIDEO_PLUGINS}" |
| 63 | |
| 64 | RRECOMMENDS_gstreamer1.0-meta-video = "\ |
| 65 | gstreamer1.0-meta-audio" |