blob: 50ad6ba5eb721572b32267711bae0ae02c1b1a50 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A multi-platform support library with a focus on asynchronous I/O"
2HOMEPAGE = "https://github.com/libuv/libuv"
3DESCRIPTION = "libuv is a multi-platform support library with a focus on asynchronous I/O. It was primarily developed for use by Node.js, but it's also used by Luvit, Julia, pyuv, and others."
4BUGTRACKER = "https://github.com/libuv/libuv/issues"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=74b6f2f7818a4e3a80d03556f71b129b \
7 file://LICENSE-extra;md5=f9307417749e19bd1d6d68a394b49324"
8
9SRCREV = "be6b81a352d17513c95be153afcb3148f1a451cd"
10SRC_URI = "git://github.com/libuv/libuv.git;branch=v1.x;protocol=https"
11UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
12
13S = "${WORKDIR}/git"
14
15inherit autotools
16
17do_configure() {
18 ${S}/autogen.sh || bbnote "${PN} failed to autogen.sh"
19 oe_runconf
20}
21
22BBCLASSEXTEND = "native"