blob: dcbf6e88a8e2caffb5aa2e3322ebcdb6717b7b6f [file] [log] [blame]
Howard Chiu0eb09a12021-12-09 13:27:04 +08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
3
4inherit allarch systemd
5
6RDEPENDS:${PN} += "bash"
7RDEPENDS:${PN} += "libgpiod-tools"
8
9SRC_URI += " \
10 file://bletchley-early-sys-init \
11 file://bletchley-sys-init.service \
12 "
13
14SYSTEMD_PACKAGES = "${PN}"
15SYSTEMD_SERVICE:${PN}:append = " \
16 bletchley-sys-init.service \
17 "
18
19do_install() {
20 install -d ${D}${libexecdir}
21 install -m 0755 ${WORKDIR}/bletchley-early-sys-init ${D}${libexecdir}
22
23 install -d ${D}${systemd_system_unitdir}
24 install -m 0644 ${WORKDIR}/bletchley-sys-init.service ${D}${systemd_system_unitdir}
25}