blob: ba38d107f7ab8267b405ead2f4f3b46d91b32d78 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "libsecret is a library for storing and retrieving passwords and other secrets"
2LICENSE = "LGPLv2.1"
3LIC_FILES_CHKSUM = "file://COPYING;md5=23c2a5e0106b99d75238986559bb5fc6"
4
5inherit gnomebase gtk-doc vala gobject-introspection manpages
6
7DEPENDS += "glib-2.0 libgcrypt gettext-native"
8
9PACKAGECONFIG[manpages] = "--enable-manpages, --disable-manpages, libxslt-native xmlto-native"
10
11SRC_URI[archive.md5sum] = "376153ece17081eb5410870e0dc5c031"
12SRC_URI[archive.sha256sum] = "0d66fe1fc4561b3e046ee281d7c5a703a9baac88a8c4fb42ebc739d31dabd487"
13
14# http://errors.yoctoproject.org/Errors/Details/20228/
15ARM_INSTRUCTION_SET_armv4 = "arm"
16ARM_INSTRUCTION_SET_armv5 = "arm"
17ARM_INSTRUCTION_SET_armv6 = "arm"
18
19# vapigen.m4 bundled with the tarball does not yet have our cross-compilation fixes
20do_configure_prepend() {
21 rm -f ${S}/build/m4/vapigen.m4
22}