Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "The GIMP is the GNU Image Manipulation Program" |
| 2 | HOMEPAGE = "http://www.gimp.org" |
| 3 | SECTION = "x11/graphics" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 4 | LICENSE = "GPL-3.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=c678957b0c8e964aa6c70fd77641a71e" |
| 6 | |
| 7 | DEPENDS = " \ |
| 8 | alsa-lib \ |
| 9 | atk \ |
| 10 | cairo \ |
| 11 | fontconfig \ |
| 12 | freetype \ |
| 13 | gdk-pixbuf-native \ |
| 14 | intltool-native \ |
| 15 | libxslt-native \ |
| 16 | gegl-native \ |
| 17 | dbus-glib \ |
| 18 | gtk+ \ |
| 19 | babl \ |
| 20 | gegl \ |
| 21 | libmypaint \ |
| 22 | mypaint-brushes-1.0 \ |
| 23 | gexiv2 \ |
| 24 | jpeg \ |
| 25 | libmng \ |
| 26 | libpng \ |
| 27 | libexif \ |
| 28 | tiff \ |
| 29 | lcms \ |
| 30 | poppler \ |
| 31 | poppler-data \ |
| 32 | jasper \ |
| 33 | bzip2 \ |
| 34 | libgudev \ |
| 35 | libmng \ |
| 36 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)} \ |
| 37 | " |
| 38 | DEPENDS:append:libc-musl = " libexecinfo" |
| 39 | |
| 40 | inherit features_check gnomebase gtk-icon-cache gtk-doc mime-xdg |
| 41 | |
| 42 | REQUIRED_DISTRO_FEATURES = "x11" |
| 43 | |
| 44 | SHPV = "${@gnome_verdir("${PV}")}" |
| 45 | |
| 46 | SRC_URI = "https://download.gimp.org/pub/${BPN}/v${SHPV}/${BP}.tar.bz2" |
| 47 | SRC_URI[sha256sum] = "88815daa76ed7d4277eeb353358bafa116cd2fcd2c861d95b95135c1d52b67dc" |
| 48 | |
| 49 | EXTRA_OECONF = "--disable-python \ |
| 50 | --without-webkit \ |
| 51 | --disable-check-update \ |
| 52 | --without-wmf" |
| 53 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 54 | EXTRA_OECONF:append:toolchain-clang:arm = " --disable-vector-icons" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 55 | EXTRA_OECONF:append:toolchain-clang:riscv32 = " --disable-vector-icons" |
| 56 | EXTRA_OECONF:append:toolchain-clang:mips = " --disable-vector-icons" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 57 | EXTRA_OECONF:append:toolchain-clang:x86 = " --disable-vector-icons" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 58 | EXTRA_OECONF:append:powerpc = " --disable-vector-icons" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 59 | |
| 60 | do_configure:append() { |
| 61 | find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g |
| 62 | find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g |
| 63 | } |
| 64 | |
| 65 | do_compile:prepend() { |
| 66 | # Let native babl/gegl find their plugins |
| 67 | export BABL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'babl-*'` |
| 68 | export GEGL_PATH=`find ${STAGING_LIBDIR_NATIVE} -maxdepth 1 -name 'gegl-*'` |
| 69 | } |
| 70 | |
| 71 | FILES:${PN} += "${datadir}/metainfo" |
| 72 | |
| 73 | RDEPENDS:${PN} += "mypaint-brushes-1.0" |