Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 1 | SUMMARY = "Network benchmark tool" |
| 2 | DESCRIPTION = "\ |
| 3 | iperf is a tool for active measurements of the maximum achievable bandwidth \ |
| 4 | on IP networks. It supports tuning of various parameters related to timing, \ |
| 5 | protocols, and buffers. For each test it reports the bandwidth, loss, and \ |
| 6 | other parameters." |
| 7 | |
| 8 | HOMEPAGE = "http://software.es.net/iperf/" |
| 9 | SECTION = "console/network" |
| 10 | BUGTRACKER = "https://github.com/esnet/iperf/issues" |
| 11 | AUTHOR = "ESNET <info@es.net>, Lawrence Berkeley National Laboratory <websupport@lbl.gov>" |
| 12 | |
| 13 | LICENSE = "BSD-3-Clause" |
| 14 | LIC_FILES_CHKSUM = "file://LICENSE;md5=68ae8cfc577a2c8c51bb51e9628e80b7" |
| 15 | |
| 16 | SRC_URI = "git://github.com/esnet/iperf.git;branch=master;protocol=https \ |
| 17 | file://0002-Remove-pg-from-profile_CFLAGS.patch \ |
| 18 | file://0001-configure.ac-check-for-CPP-prog.patch \ |
| 19 | " |
| 20 | |
| 21 | SRCREV = "76bd67f6e90e239a7686202d2b1b595159826d24" |
| 22 | |
| 23 | S = "${WORKDIR}/git" |
| 24 | |
| 25 | inherit autotools |
| 26 | |
| 27 | PACKAGECONFIG ?= "openssl" |
| 28 | |
| 29 | PACKAGECONFIG[lksctp] = "ac_cv_header_netinet_sctp_h=yes,ac_cv_header_netinet_sctp_h=no,lksctp-tools" |
| 30 | PACKAGECONFIG[openssl] = "--with-openssl=${RECIPE_SYSROOT}${prefix},--without-openssl,openssl" |
| 31 | |
| 32 | CFLAGS += "-D_GNU_SOURCE" |