Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | # Copyright (C) 2017 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "A console-based network monitoring utility" |
| 5 | DESCRIPTION = "IPTraf-ng is a console-based network monitoring utility. IPTraf gathers \ |
| 6 | data like TCP connection packet and byte counts, interface statistics \ |
| 7 | and activity indicators, TCP/UDP traffic breakdowns, and LAN station \ |
| 8 | packet and byte counts. IPTraf-ng features include an IP traffic monitor \ |
| 9 | which shows TCP flag information, packet and byte counts, ICMP \ |
| 10 | details, OSPF packet types, and oversized IP packet warnings; \ |
| 11 | interface statistics showing IP, TCP, UDP, ICMP, non-IP and other IP \ |
| 12 | packet counts, IP checksum errors, interface activity and packet size \ |
| 13 | counts; a TCP and UDP service monitor showing counts of incoming and \ |
| 14 | outgoing packets for common TCP and UDP application ports, a LAN \ |
| 15 | statistics module that discovers active hosts and displays statistics \ |
| 16 | about their activity; TCP, UDP and other protocol display filters so \ |
| 17 | you can view just the traffic you want; logging; support for Ethernet, \ |
| 18 | FDDI, ISDN, SLIP, PPP, and loopback interfaces; and utilization of the \ |
| 19 | built-in raw socket interface of the Linux kernel, so it can be used \ |
| 20 | on a wide variety of supported network cards." |
| 21 | |
| 22 | HOMEPAGE = "https://fedorahosted.org/iptraf-ng/" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 23 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 24 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e2b3850593b899b1a17594ed4cc4c731" |
| 25 | DEPENDS = "ncurses" |
| 26 | |
| 27 | SRC_URI = "https://src.fedoraproject.org/repo/pkgs/iptraf-ng/v${PV}.tar.gz/sha512/44d36fc92cdbf379f62cb63638663c3ee610225b9c28d60ee55e62e358f398a6b0db281129327b3472e45fb553ee3dd605af09c129f2233f8839ae3dbd799384/v${PV}.tar.gz \ |
| 28 | file://iptraf-ng-tmpfiles.conf \ |
| 29 | file://ncurses-config.patch \ |
| 30 | file://0001-make-Make-CC-weak-assignment.patch \ |
| 31 | " |
| 32 | SRC_URI[sha256sum] = "9f5cef584065420dea1ba32c86126aede1fa9bd25b0f8362b0f9fd9754f00870" |
| 33 | |
| 34 | inherit pkgconfig |
| 35 | |
| 36 | CFLAGS += "-D_GNU_SOURCE" |
| 37 | |
| 38 | do_compile() { |
| 39 | oe_runmake |
| 40 | } |
| 41 | |
| 42 | do_install() { |
| 43 | oe_runmake DESTDIR=${D} install |
| 44 | install -D -m 0644 -p ${S}/iptraf-ng-logrotate.conf ${D}${sysconfdir}/logrotate.d/iptraf-ng |
| 45 | install -Dm 0644 ${WORKDIR}/iptraf-ng-tmpfiles.conf ${D}${libdir}/tmpfiles.d/iptraf-ng-tmpfiles.conf |
| 46 | } |
| 47 | |
| 48 | FILES:${PN} += "${libdir}/tmpfiles.d" |
| 49 | PROVIDES = "iptraf" |
| 50 | RPROVIDES:${PN} += "iptraf" |
| 51 | RREPLACES:${PN} += "iptraf" |
| 52 | RCONFLICTS:${PN} += "iptraf" |
| 53 | |