Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "A top utility for I/O" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 2 | LICENSE = "GPL-2.0-or-later" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=48e7be78bd2671d08c9c3bad71f1cfaa" |
| 4 | |
| 5 | DEPENDS = "ncurses" |
| 6 | |
| 7 | SRC_URI = "https://github.com/Tomas-M/iotop/releases/download/v1.21/iotop-1.21.tar.xz" |
| 8 | SRC_URI[sha256sum] = "7b4862ebc93909a3f800193140ca2464e926291a9c873b50dc31fa77e6d9383e" |
| 9 | UPSTREAM_CHECK_URI = "https://github.com/Tomas-M/iotop/releases" |
| 10 | |
| 11 | inherit pkgconfig |
| 12 | |
| 13 | EXTRA_OEMAKE = "V=1 STRIP=true" |
| 14 | # Fixes llvm-bc70b5.o: can't link soft-float modules with double-float modules |
| 15 | EXTRA_OEMAKE:append:toolchain-clang:riscv64 = " NO_FLTO=1" |
| 16 | EXTRA_OEMAKE:append:toolchain-clang:riscv32 = " NO_FLTO=1" |
| 17 | |
| 18 | # Workaround BFD linker crash with clang on arm |
| 19 | # revisit when upgrading binutils and see if its fixed |
| 20 | LDFLAGS:append:toolchain-clang:arm = " -fuse-ld=lld" |
| 21 | |
| 22 | do_install() { |
| 23 | oe_runmake install DESTDIR=${D} |
| 24 | } |