Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 1 | SUMMARY = "YANG data modeling language library" |
| 2 | DESCRIPTION = "libyang is a YANG data modelling language parser and toolkit written (and providing API) in C." |
| 3 | HOMEPAGE = "https://github.com/CESNET/libyang" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=f3916d7d8d42a6508d0ea418cfff10ad" |
| 8 | |
| 9 | SRCREV = "a0cc89516ab5eca84d01c85309f320a94752a64c" |
| 10 | |
| 11 | SRC_URI = "git://github.com/CESNET/libyang.git;branch=master;protocol=https \ |
| 12 | file://libyang-add-stdint-h.patch \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | # Due to valgrind not supported on these arches: |
| 19 | COMPATIBLE_HOST:riscv32 = "null" |
| 20 | COMPATIBLE_HOST:armv5 = "null" |
| 21 | COMPATIBLE_HOST:riscv64 = "null" |
| 22 | |
| 23 | # Main dependencies |
| 24 | inherit cmake pkgconfig lib_package binconfig-disabled ptest |
| 25 | DEPENDS = "libpcre2" |
| 26 | DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'cmocka', '', d)}" |
| 27 | BINCONFIG = "${bindir}/pcre2-config" |
| 28 | |
| 29 | # Ptest dependencies |
| 30 | RDEPENDS:${PN}-ptest += "valgrind" |
| 31 | |
| 32 | EXTRA_OECMAKE = "-DCMAKE_BUILD_TYPE=Release" |
| 33 | EXTRA_OECMAKE += " ${@bb.utils.contains('PTEST_ENABLED', '1', '-DENABLE_TESTS=ON', '', d)}" |
| 34 | |
| 35 | do_install_ptest () { |
| 36 | cp -fR ${B}/tests/ ${D}${PTEST_PATH}/ |
| 37 | } |
| 38 | |