Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | require ttf.inc |
| 2 | |
| 3 | SUMMARY = "Japanese TrueType fonts from Vine Linux" |
| 4 | AUTHOR = "Contributor: noonov <noonov@gmail.com>" |
| 5 | HOMEPAGE = "http://vlgothic.dicey.org/" |
| 6 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 7 | LICENSE = "ttf-mplus & BSD-3-Clause" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENSE.en;md5=cc06b20e7a20bdf6c989624405378303 \ |
| 9 | file://LICENSE_E.mplus;md5=1c4767416f20215f1e61b970f2117db9 \ |
| 10 | " |
| 11 | |
| 12 | SRC_URI = "https://osdn.jp/dl/vlgothic/VLGothic-${PV}.tar.xz" |
| 13 | |
| 14 | SRC_URI[sha256sum] = "297a3813675fbea12c5813b55a78091c9a5946515ecbf9fde8b8102e01c579f4" |
| 15 | |
| 16 | S = "${WORKDIR}/VLGothic" |
| 17 | |
| 18 | do_install:append () { |
| 19 | install -D -m644 ${S}/LICENSE_E.mplus ${D}${datadir}/licenses/${PN}/COPYING_MPLUS.txt |
| 20 | install -D -m644 ${S}/README.sazanami ${D}${datadir}/licenses/${PN}/COPYING_SAZANAMI.txt |
| 21 | install -D -m644 ${S}/LICENSE.en ${D}${datadir}/licenses/${PN}/COPYING_VLGOTHIC.txt |
| 22 | } |
| 23 | |
| 24 | PACKAGES = "${PN}" |
| 25 | FONT_PACKAGES = "${PN}" |
| 26 | |
| 27 | FILES:${PN} = "${datadir}/fonts/truetype ${datadir}/licenses" |