Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Linux Key Management Utilities" |
| 2 | DESCRIPTION = "\ |
| 3 | Utilities to control the kernel key management facility and to provide \ |
| 4 | a mechanism by which the kernel call back to userspace to get a key \ |
| 5 | instantiated. \ |
| 6 | " |
| 7 | HOMEPAGE = "http://people.redhat.com/dhowells/keyutils" |
| 8 | SECTION = "base" |
| 9 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 10 | LICENSE = "LGPL-2.1-or-later & GPL-2.0-or-later" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 11 | |
| 12 | LIC_FILES_CHKSUM = "file://LICENCE.GPL;md5=5f6e72824f5da505c1f4a7197f004b45 \ |
| 13 | file://LICENCE.LGPL;md5=7d1cacaa3ea752b72ea5e525df54a21f" |
| 14 | |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 15 | inherit siteinfo autotools-brokensep ptest |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 16 | |
| 17 | SRC_URI = "http://people.redhat.com/dhowells/keyutils/${BP}.tar.bz2 \ |
| 18 | file://keyutils-test-fix-output-format.patch \ |
| 19 | file://keyutils-fix-error-report-by-adding-default-message.patch \ |
| 20 | file://run-ptest \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 21 | file://fix_library_install_path.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 22 | " |
| 23 | |
Brad Bishop | 0e2770c | 2020-01-21 07:31:46 -0500 | [diff] [blame] | 24 | SRC_URI[md5sum] = "919af7f33576816b423d537f8a8692e8" |
| 25 | SRC_URI[sha256sum] = "c8b15722ae51d95b9ad76cc6d49a4c2cc19b0c60f72f61fb9bf43eea7cbd64ce" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 26 | |
| 27 | EXTRA_OEMAKE = "'CFLAGS=${CFLAGS} -Wall' \ |
| 28 | NO_ARLIB=1 \ |
| 29 | BINDIR=${base_bindir} \ |
| 30 | SBINDIR=${base_sbindir} \ |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 31 | LIBDIR=${libdir} \ |
| 32 | USRLIBDIR=${libdir} \ |
| 33 | INCLUDEDIR=${includedir} \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 34 | ETCDIR=${sysconfdir} \ |
| 35 | SHAREDIR=${datadir}/keyutils \ |
| 36 | MANDIR=${datadir}/man \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 37 | BUILDFOR=${SITEINFO_BITS}-bit \ |
| 38 | NO_GLIBC_KEYERR=1 \ |
| 39 | " |
| 40 | |
| 41 | do_install () { |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 42 | install -d ${D}/${libdir}/pkgconfig |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 43 | oe_runmake DESTDIR=${D} install |
| 44 | } |
| 45 | |
| 46 | do_install_ptest () { |
| 47 | cp -r ${S}/tests ${D}${PTEST_PATH}/ |
| 48 | sed -i -e 's/OSDIST=Unknown/OSDIST=${DISTRO}/' ${D}${PTEST_PATH}/tests/prepare.inc.sh |
| 49 | } |
| 50 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 51 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 52 | RDEPENDS:${PN}-ptest += "lsb-release" |
| 53 | RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils" |
| 54 | RDEPENDS:${PN}-ptest:append:libc-musl = " musl-utils" |
Brad Bishop | 15ae250 | 2019-06-18 21:44:24 -0400 | [diff] [blame] | 55 | |
| 56 | BBCLASSEXTEND = "native nativesdk" |