Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | SUMMARY = "Library for interfacing with common SoC peripherals" |
| 2 | DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \ |
| 3 | found in SoC (System on Chips) through generic Linux Kernel interfaces." |
| 4 | |
| 5 | HOMEPAGE = "https://github.com/jackmitch/libsoc" |
| 6 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 7 | LICENSE = "LGPL-2.1-only" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5" |
| 9 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 10 | inherit autotools pkgconfig python3-dir |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 11 | |
| 12 | SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | SRC_URI = "git://github.com/jackmitch/libsoc.git;branch=master;protocol=https" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | BOARD ??= "devboard" |
| 18 | |
| 19 | PACKAGECONFIG ?= "" |
| 20 | |
| 21 | PACKAGECONFIG[disabledebug] = "--disable-debug,," |
| 22 | PACKAGECONFIG[allboardconfigs] = "--with-board-configs,," |
| 23 | PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},," |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 24 | PACKAGECONFIG[python] = "--enable-python=${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN},,${PYTHON_PN} ${PYTHON_PN}-native" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 25 | |
| 26 | PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \ |
| 27 | '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}" |
| 28 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 29 | RDEPENDS:${PN} = "libgcc" |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 30 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 31 | FILES:${PYTHON_PN}-libsoc-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*/*.a" |
| 32 | FILES:${PYTHON_PN}-libsoc += "${PYTHON_SITEPACKAGES_DIR}" |