Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "A simple, sane and efficient module to slurp a file" |
| 2 | DESCRIPTION = "This module provides functions for fast and correct slurping and spewing. \ |
| 3 | All functions are optionally exported. All functions throw exceptions on \ |
| 4 | errors, write functions don't return any meaningful value." |
| 5 | |
| 6 | SECTION = "libs" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 7 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 8 | |
| 9 | HOMEPAGE= "https://metacpan.org/release/File-Slurper" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \ |
| 12 | file://${COMMON_LICENSE_DIR}/GPL-1.0-or-later;md5=30c0b8a5048cc2f4be5ff15ef0d8cf61" |
| 13 | |
| 14 | SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/File-Slurper-${PV}.tar.gz" |
| 15 | |
| 16 | SRC_URI[sha256sum] = "e2f6a4029a6a242d50054044f1fb86770b9b5cc4daeb1a967f91ffb42716a8c5" |
| 17 | RDEPENDS:${PN} = " \ |
| 18 | perl-module-carp \ |
| 19 | perl-module-encode \ |
| 20 | perl-module-exporter \ |
| 21 | perl-module-perlio \ |
| 22 | perl-module-perlio-encoding \ |
| 23 | perl-module-strict \ |
| 24 | perl-module-warnings \ |
| 25 | " |
| 26 | |
| 27 | RDEPENDS:${PN}-ptest += "libtest-warnings-perl \ |
| 28 | perl-module-test-more \ |
| 29 | " |
| 30 | |
| 31 | S = "${WORKDIR}/File-Slurper-${PV}" |
| 32 | |
| 33 | inherit cpan ptest-perl |
| 34 | |
| 35 | BBCLASSEXTEND = "native" |