Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 1 | DESCRIPTION = "GUI tool for storage configuration using blivet library" |
| 2 | HOMEPAGE = "https://github.com/rhinstaller/blivet-gui" |
| 3 | LICENSE = "GPL-2.0-or-later" |
| 4 | SECTION = "devel/python" |
| 5 | |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | B = "${S}" |
| 10 | |
| 11 | SRCREV = "42512ee48494cee71febf04078d9774f0146a085" |
| 12 | SRC_URI = "git://github.com/storaged-project/blivet-gui.git;branch=master;protocol=https \ |
| 13 | file://0001-Use-setuptools-instead-of-distutils-in-setup.py.patch \ |
| 14 | " |
| 15 | |
| 16 | inherit features_check |
| 17 | REQUIRED_DISTRO_FEATURES = "x11 systemd" |
| 18 | |
| 19 | inherit setuptools3_legacy python3native |
| 20 | |
| 21 | PIP_INSTALL_PACKAGE = "blivet_gui" |
| 22 | |
| 23 | RDEPENDS:${PN} = "python3-pygobject python3 \ |
| 24 | python3-blivet gtk+3 \ |
| 25 | python3-pid libreport \ |
| 26 | " |
| 27 | |
| 28 | FILES:${PN} += " \ |
| 29 | ${datadir}/* \ |
| 30 | " |