Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | BPN = "qemu" |
| 2 | |
| 3 | inherit python3-dir |
| 4 | |
| 5 | require qemu-native.inc |
| 6 | |
| 7 | # As some of the files installed by qemu-native and qemu-system-native |
| 8 | # are the same, we depend on qemu-native to get the full installation set |
| 9 | # and avoid file clashes |
| 10 | DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native meson-native ninja-native" |
| 11 | |
| 12 | EXTRA_OECONF:append = " --target-list=${@get_qemu_system_target_list(d)}" |
| 13 | |
| 14 | PACKAGECONFIG ??= "fdt alsa kvm pie \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame^] | 15 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer epoxy', '', d)} \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 16 | " |
| 17 | |
| 18 | # Handle distros such as CentOS 5 32-bit that do not have kvm support |
| 19 | PACKAGECONFIG:remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}" |
| 20 | |
| 21 | do_install:append() { |
| 22 | install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu |
| 23 | |
| 24 | # The following is also installed by qemu-native |
| 25 | rm -f ${D}${datadir}/qemu/trace-events-all |
| 26 | rm -rf ${D}${datadir}/qemu/keymaps |
| 27 | rm -rf ${D}${datadir}/icons/ |
| 28 | rm -rf ${D}${includedir}/qemu-plugin.h |
| 29 | |
| 30 | # Install qmp.py to be used with testimage |
| 31 | install -D ${S}/python/qemu/qmp/__init__.py ${D}${libdir}/qemu-python/qmp.py |
| 32 | } |