Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # Version 5 of the Berkeley DB from Sleepycat |
| 2 | # |
| 3 | # At present this package only installs the DB code |
| 4 | # itself (shared libraries, .a in the dev package), |
| 5 | # documentation and headers. |
| 6 | # |
| 7 | # The headers have the same names as those as v3 |
| 8 | # of the DB, only one version can be used *for dev* |
| 9 | # at once - DB3 and DB5 can both be installed on the |
| 10 | # same system at the same time if really necessary. |
| 11 | SECTION = "libs" |
| 12 | SUMMARY = "Berkeley Database v5" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 13 | HOMEPAGE = "http://www.oracle.com/technetwork/database/database-technologies/berkeleydb/overview/index.html" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 14 | LICENSE = "Sleepycat" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 15 | RCONFLICTS_${PN} = "db3" |
| 16 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | CVE_PRODUCT = "oracle_berkeley_db" |
| 18 | CVE_VERSION = "11.2.${PV}" |
| 19 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 20 | PR = "r1" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | PE = "1" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 22 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 23 | SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 24 | SRC_URI += "file://fix-parallel-build.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 25 | file://0001-atomic-Rename-local-__atomic_compare_exchange-to-avo.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 26 | file://0001-configure-Add-explicit-tag-options-to-libtool-invoca.patch \ |
| 27 | file://sequence-type.patch \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | file://0001-Fix-libc-compatibility-by-renaming-atomic_init-API.patch \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 30 | # We are not interested in official latest 6.x versions; |
| 31 | # let's track what debian is using. |
| 32 | UPSTREAM_CHECK_URI = "${DEBIAN_MIRROR}/main/d/db5.3/" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 33 | UPSTREAM_CHECK_REGEX = "db5\.3_(?P<pver>\d+(\.\d+)+).+\.orig" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 34 | |
| 35 | SRC_URI[md5sum] = "b99454564d5b4479750567031d66fe24" |
| 36 | SRC_URI[sha256sum] = "e0a992d740709892e81f9d93f06daf305cf73fb81b545afe72478043172c3628" |
| 37 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 38 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ed1158e31437f4f87cdd4ab2b8613955" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 39 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 40 | inherit autotools |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 41 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 42 | # The executables go in a separate package - typically there |
| 43 | # is no need to install these unless doing real database |
| 44 | # management on the system. |
| 45 | inherit lib_package |
| 46 | |
| 47 | PACKAGES =+ "${PN}-cxx" |
| 48 | FILES_${PN}-cxx = "${libdir}/*cxx*so" |
| 49 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 50 | # The dev package has the .so link (as in db3) and the .a's - |
| 51 | # it is therefore incompatible (cannot be installed at the |
| 52 | # same time) as the db3 package |
| 53 | # sort out the .so since they do version prior to the .so |
| 54 | SOLIBS = "-5*.so" |
| 55 | FILES_SOLIBSDEV = "${libdir}/libdb.so ${libdir}/libdb_cxx.so" |
| 56 | |
| 57 | #configuration - set in local.conf to override |
| 58 | # All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix) |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 59 | DB5_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-compat185 --disable-sql" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 60 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 61 | EXTRA_OECONF = "${DB5_CONFIG} --enable-shared --enable-cxx --with-sysroot STRIP=true" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 62 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 63 | PACKAGECONFIG[verify] = "--enable-verify, --disable-verify" |
| 64 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 65 | EXTRA_OEMAKE += "LIBTOOL='./${HOST_SYS}-libtool'" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 66 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 67 | EXTRA_AUTORECONF += "--exclude=autoheader -I ${S}/dist/aclocal -I${S}/dist/aclocal_java" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 68 | AUTOTOOLS_SCRIPT_PATH = "${S}/dist" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 69 | |
| 70 | # Cancel the site stuff - it's set for db3 and destroys the |
| 71 | # configure. |
| 72 | CONFIG_SITE = "" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 73 | |
| 74 | oe_runconf_prepend() { |
| 75 | . ${S}/dist/RELEASE |
| 76 | # Edit version information we couldn't pre-compute. |
| 77 | sed -i -e "s/__EDIT_DB_VERSION_FAMILY__/$DB_VERSION_FAMILY/g" \ |
| 78 | -e "s/__EDIT_DB_VERSION_RELEASE__/$DB_VERSION_RELEASE/g" \ |
| 79 | -e "s/__EDIT_DB_VERSION_MAJOR__/$DB_VERSION_MAJOR/g" \ |
| 80 | -e "s/__EDIT_DB_VERSION_MINOR__/$DB_VERSION_MINOR/g" \ |
| 81 | -e "s/__EDIT_DB_VERSION_PATCH__/$DB_VERSION_PATCH/g" \ |
| 82 | -e "s/__EDIT_DB_VERSION_STRING__/$DB_VERSION_STRING/g" \ |
| 83 | -e "s/__EDIT_DB_VERSION_FULL_STRING__/$DB_VERSION_FULL_STRING/g" \ |
| 84 | -e "s/__EDIT_DB_VERSION_UNIQUE_NAME__/$DB_VERSION_UNIQUE_NAME/g" \ |
| 85 | -e "s/__EDIT_DB_VERSION__/$DB_VERSION/g" ${S}/dist/configure |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 86 | } |
| 87 | |
| 88 | do_compile_prepend() { |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 89 | # Stop libtool adding RPATHs |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 90 | sed -i -e 's|hardcode_into_libs=yes|hardcode_into_libs=no|' ${B}/${HOST_SYS}-libtool |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 91 | } |
| 92 | |
| 93 | do_install_append() { |
| 94 | mkdir -p ${D}/${includedir}/db51 |
| 95 | mv ${D}/${includedir}/db.h ${D}/${includedir}/db51/. |
| 96 | mv ${D}/${includedir}/db_cxx.h ${D}/${includedir}/db51/. |
| 97 | ln -s db51/db.h ${D}/${includedir}/db.h |
| 98 | ln -s db51/db_cxx.h ${D}/${includedir}/db_cxx.h |
| 99 | |
| 100 | # The docs end up in /usr/docs - not right. |
| 101 | if test -d "${D}/${prefix}/docs" |
| 102 | then |
| 103 | mkdir -p "${D}/${datadir}" |
| 104 | test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}" |
| 105 | mv "${D}/${prefix}/docs" "${D}/${docdir}" |
| 106 | fi |
| 107 | |
| 108 | chown -R root:root ${D} |
| 109 | } |
| 110 | |
| 111 | INSANE_SKIP_${PN} = "dev-so" |
| 112 | INSANE_SKIP_${PN}-cxx = "dev-so" |
| 113 | |
| 114 | BBCLASSEXTEND = "native nativesdk" |