Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | do_install() { |
| 2 | oe_runmake install_root=${D} install |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 3 | install -Dm 0644 ${WORKDIR}/etc/ld.so.conf ${D}/${sysconfdir}/ld.so.conf |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 4 | install -d ${D}${localedir} |
| 5 | make -f ${WORKDIR}/generate-supported.mk IN="${S}/localedata/SUPPORTED" OUT="${WORKDIR}/SUPPORTED" |
| 6 | # get rid of some broken files... |
| 7 | for i in ${GLIBC_BROKEN_LOCALES}; do |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 8 | sed -i "/$i/d" ${WORKDIR}/SUPPORTED |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 9 | done |
| 10 | rm -f ${D}${sysconfdir}/rpc |
| 11 | rm -rf ${D}${datadir}/zoneinfo |
| 12 | rm -rf ${D}${libexecdir}/getconf |
| 13 | } |
| 14 | |
| 15 | def get_libc_fpu_setting(bb, d): |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | if d.getVar('TARGET_FPU') in [ 'soft', 'ppc-efd' ]: |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 17 | return "--without-fp" |
| 18 | return "" |
| 19 | |
| 20 | python populate_packages_prepend () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 21 | if d.getVar('DEBIAN_NAMES'): |
| 22 | pkgs = d.getVar('PACKAGES').split() |
| 23 | bpn = d.getVar('BPN') |
| 24 | prefix = d.getVar('MLPREFIX') or "" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 25 | # Set the base package... |
| 26 | d.setVar('PKG_' + prefix + bpn, prefix + 'libc6') |
| 27 | libcprefix = prefix + bpn + '-' |
| 28 | for p in pkgs: |
| 29 | # And all the subpackages. |
| 30 | if p.startswith(libcprefix): |
| 31 | renamed = p.replace(bpn, 'libc6', 1) |
| 32 | d.setVar('PKG_' + p, renamed) |
| 33 | # For backward compatibility with old -dbg package |
| 34 | d.appendVar('RPROVIDES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg') |
| 35 | d.appendVar('RCONFLICTS_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg') |
| 36 | d.appendVar('RREPLACES_' + libcprefix + 'dbg', ' ' + prefix + 'libc-dbg') |
| 37 | } |