Mike Garrett | 4eb108b | 2021-08-27 15:51:09 -0500 | [diff] [blame] | 1 | # TODO: Manually copy the U-Boot signing key and customer-key-block here: |
| 2 | HPE_GXP_KEY_FILES_DIR = "${COREBASE}/meta-hpe/meta-gxp/recipes-bsp/image/files" |
| 3 | |
| 4 | inherit deploy |
| 5 | |
| 6 | do_deploy () { |
| 7 | install -d ${DEPLOYDIR} |
| 8 | |
| 9 | # Copy in the bootblock |
| 10 | install -m 644 ${HPE_GXP_KEY_FILES_DIR}/gxp-bootblock.bin ${DEPLOYDIR}/gxp-bootblock.bin |
| 11 | |
| 12 | # Copy in files from the files subdirectory |
| 13 | install -m 644 ${HPE_GXP_KEY_FILES_DIR}/header.sig ${DEPLOYDIR}/hpe-uboot-header.section |
| 14 | |
| 15 | # Copy in the U-Boot signing key |
| 16 | install -m 644 ${HPE_GXP_KEY_FILES_DIR}/private_key.pem ${DEPLOYDIR}/hpe-uboot-signing-key.pem |
| 17 | |
| 18 | # Copy in the customer keyblock |
| 19 | install -m 644 ${HPE_GXP_KEY_FILES_DIR}/customer-key-block ${DEPLOYDIR}/customer-key-block |
| 20 | } |