Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "openbox Window Manager" |
| 2 | SECTION = "x11/wm" |
| 3 | DEPENDS = "glib-2.0 pango libxml2 virtual/libx11 libcroco librsvg gdk-pixbuf" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-or-later" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 6 | |
| 7 | SRC_URI = " \ |
| 8 | http://icculus.org/openbox/releases/openbox-${PV}.tar.gz \ |
| 9 | file://0001-Makefile.am-avoid-race-when-creating-autostart-direc.patch \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | file://0001-openbox-xdg-autostart-convert-to-python3.patch \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 11 | " |
| 12 | |
| 13 | SRC_URI[md5sum] = "b72794996c6a3ad94634727b95f9d204" |
| 14 | SRC_URI[sha256sum] = "8b4ac0760018c77c0044fab06a4f0c510ba87eae934d9983b10878483bde7ef7" |
| 15 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 16 | inherit autotools gettext update-alternatives pkgconfig features_check |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | # depends on virtual/libx11 |
| 18 | REQUIRED_DISTRO_FEATURES = "x11" |
| 19 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 20 | ALTERNATIVE:${PN}-core = "x-window-manager x-session-manager" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 21 | ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/openbox" |
| 22 | ALTERNATIVE_PRIORITY[x-window-manager] = "10" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 23 | ALTERNATIVE_TARGET[x-session-manager] = "${bindir}/openbox-session" |
| 24 | ALTERNATIVE_PRIORITY[x-session-manager] = "100" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 25 | |
| 26 | PACKAGECONFIG ??= "" |
| 27 | PACKAGECONFIG[imlib2] = "--enable-imlib2,--disable-imlib2,imlib2" |
| 28 | PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification" |
| 29 | PACKAGECONFIG[xrandr] = "--enable-xrandr,--disable-xrandr,libxrandr" |
| 30 | PACKAGECONFIG[xinerama] = "--enable-xinerama,--disable-xinerama,libxinerama" |
| 31 | PACKAGECONFIG[xcursor] = "--enable-xcursor,--disable-xcursor,libxcursor" |
| 32 | |
| 33 | PACKAGES =+ "${PN}-core ${PN}-lxde ${PN}-gnome ${PN}-config" |
| 34 | |
| 35 | PACKAGES_DYNAMIC += "^${PN}-theme-.*" |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | python populate_packages:prepend() { |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 38 | theme_dir = d.expand('${datadir}/themes/') |
| 39 | theme_name = d.expand('${PN}-theme-%s') |
| 40 | do_split_packages(d, theme_dir, '(.*)', theme_name, '${PN} theme for %s', extra_depends='', allow_dirs=True) |
| 41 | } |
| 42 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 43 | FILES:${PN}-core = "${bindir}/openbox ${bindir}/openbox-session ${libdir}/*${SOLIBS}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | FILES:${PN}-lxde += "${datadir}/lxde/ \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 46 | ${datadir}/lxpanel \ |
| 47 | ${datadir}/xsessions \ |
| 48 | ${datadir}/icons" |
| 49 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | FILES:${PN}-gnome += " \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 51 | ${bindir}/openbox-gnome-session \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 52 | ${datadir}/gnome \ |
| 53 | ${datadir}/gnome-session \ |
| 54 | " |
| 55 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 56 | FILES:${PN}-config += "${sysconfdir}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 57 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 58 | RDEPENDS:${PN} += "${PN}-core ${PN}-config ${PN}-theme-clearlooks python3 python3-shell pyxdg" |