Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Proxy for UDP/TCP debug connections" |
| 2 | DESCRIPTION = "The agent-proxy will forward tcp or udp connections as well as allow for script multiplexing of terminal sessions." |
| 3 | HOMEPAGE = "http://kgdb.wiki.kernel.org/" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 4 | LICENSE = "GPL-2.0-only" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a" |
| 6 | |
| 7 | SECTION = "devel" |
| 8 | |
| 9 | EXTRA_OEMAKE = "'CC=${CC}'" |
| 10 | |
Brad Bishop | b809eb9 | 2019-09-18 06:27:43 -0400 | [diff] [blame] | 11 | SRCREV = "468fe4c31e6c62c9bbb328b06ba71eaf7be0b76a" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 12 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 13 | SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kgdb/agent-proxy.git;protocol=git;branch=master \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | file://0001-Makefile-Add-LDFLAGS-variable.patch \ |
| 15 | " |
| 16 | |
| 17 | BBCLASSEXTEND = "native nativesdk" |
| 18 | |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | do_install () { |
| 22 | install -d ${D}${bindir} |
| 23 | install -m 0755 agent-proxy ${D}${bindir} |
| 24 | } |