blob: 599c490359f62849f833dda0062441cb64a4d8f9 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Improved drop-in replacement for std::function"
2DESCRIPTION = "Provides improved implementations of std::function."
3HOMEPAGE = "https://naios.github.io/function2"
4LICENSE = "BSL-1.0"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
Patrick Williams2a254922023-08-11 09:48:11 -05006SRCREV = "9e303865d14f1204f09379e37bbeb30c4375139a"
Brad Bishop19323692019-04-05 15:28:33 -04007PV .= "+git${SRCPV}"
8
Andrew Geissler595f6302022-01-24 19:11:47 +00009SRC_URI += "gitsm://github.com/Naios/function2;branch=master;protocol=https"
Brad Bishop19323692019-04-05 15:28:33 -040010
11S = "${WORKDIR}/git"
12
13inherit cmake
14inherit ptest
15
16# Installs some data to incorrect top-level /usr directory
Patrick Williams213cb262021-08-07 19:21:33 -050017do_install:append() {
Brad Bishop19323692019-04-05 15:28:33 -040018 mkdir -p ${D}/${datadir}/function2
19 mv ${D}/${prefix}/Readme.md ${D}/${datadir}/function2/
20 mv ${D}/${prefix}/LICENSE.txt ${D}/${datadir}/function2/
21}