Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Improved drop-in replacement for std::function" |
| 2 | DESCRIPTION = "Provides improved implementations of std::function." |
| 3 | HOMEPAGE = "https://naios.github.io/function2" |
| 4 | LICENSE = "BSL-1.0" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c" |
Patrick Williams | 2a25492 | 2023-08-11 09:48:11 -0500 | [diff] [blame] | 6 | SRCREV = "9e303865d14f1204f09379e37bbeb30c4375139a" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | PV .= "+git${SRCPV}" |
| 8 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 9 | SRC_URI += "gitsm://github.com/Naios/function2;branch=master;protocol=https" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit cmake |
| 14 | inherit ptest |
| 15 | |
| 16 | # Installs some data to incorrect top-level /usr directory |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 17 | do_install:append() { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | mkdir -p ${D}/${datadir}/function2 |
| 19 | mv ${D}/${prefix}/Readme.md ${D}/${datadir}/function2/ |
| 20 | mv ${D}/${prefix}/LICENSE.txt ${D}/${datadir}/function2/ |
| 21 | } |