Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Hardware identification and configuration data" |
| 2 | HOMEPAGE = "https://github.com/vcrhonek/hwdata" |
| 3 | SECTION = "System/Base" |
| 4 | |
| 5 | LICENSE = "GPL-2.0-or-later | XFree86-1.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57" |
| 7 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 8 | SRCREV = "21cb47beb1716545b25dfe8ae1b9e079c73b85d9" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 9 | SRC_URI = "git://github.com/vcrhonek/${BPN}.git;branch=master;protocol=https" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | inherit allarch |
| 14 | |
| 15 | do_configure() { |
| 16 | ${S}/configure --datadir=${datadir} --libdir=${libdir} |
| 17 | } |
| 18 | |
| 19 | do_compile[noexec] = "1" |
| 20 | |
| 21 | do_install() { |
| 22 | oe_runmake install DESTDIR=${D} |
| 23 | } |
| 24 | |
| 25 | FILES:${PN} = "${libdir}/* \ |
| 26 | ${datadir}/* " |