blob: 56d4253772607c0b08ae485895bc463f043198fa [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Hardware identification and configuration data"
2HOMEPAGE = "https://github.com/vcrhonek/hwdata"
3SECTION = "System/Base"
4
5LICENSE = "GPL-2.0-or-later | XFree86-1.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=1556547711e8246992b999edd9445a57"
7
Andrew Geissler3eeda902023-05-19 10:14:02 -05008SRCREV = "21cb47beb1716545b25dfe8ae1b9e079c73b85d9"
Andrew Geissler517393d2023-01-13 08:55:19 -06009SRC_URI = "git://github.com/vcrhonek/${BPN}.git;branch=master;protocol=https"
10
11S = "${WORKDIR}/git"
12
13inherit allarch
14
15do_configure() {
16 ${S}/configure --datadir=${datadir} --libdir=${libdir}
17}
18
19do_compile[noexec] = "1"
20
21do_install() {
22 oe_runmake install DESTDIR=${D}
23}
24
25FILES:${PN} = "${libdir}/* \
26 ${datadir}/* "