Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Real-time file compressor" |
| 2 | DESCRIPTION = "lzop is a compression utility which is designed to be a companion to gzip. \n\ |
| 3 | It is based on the LZO data compression library and its main advantages over \n\ |
| 4 | gzip are much higher compression and decompression speed at the cost of some \n\ |
| 5 | compression ratio. The lzop compression utility was designed with the goals \n\ |
| 6 | of reliability, speed, portability and with reasonable drop-in compatibility \n\ |
| 7 | to gzip." |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 8 | HOMEPAGE = "http://www.lzop.org/" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 9 | DEPENDS += "lzo" |
| 10 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | LICENSE = "GPL-2.0-or-later" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 13 | file://src/lzop.c;beginline=5;endline=21;md5=23d767de7754eb24b9e900b025cf7fc8" |
| 14 | |
| 15 | SRC_URI = "http://www.lzop.org/download/${BP}.tar.gz \ |
| 16 | file://acinclude.m4 \ |
| 17 | " |
| 18 | SRC_URI[md5sum] = "271eb10fde77a0a96b9cbf745e719ddf" |
| 19 | SRC_URI[sha256sum] = "7e72b62a8a60aff5200a047eea0773a8fb205caf7acbe1774d95147f305a2f41" |
| 20 | |
| 21 | inherit autotools |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | do_configure:prepend () { |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 24 | install -Dm 0644 ${WORKDIR}/acinclude.m4 ${S}/acinclude.m4 |
| 25 | } |
| 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |