Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "A feature rich Remote Desktop Application written in GTK+" |
| 2 | HOMEPAGE = "https://remmina.org" |
| 3 | SECTION = "Support" |
| 4 | LICENSE = "GPL-2.0-only & OpenSSL" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=dab7215512044d49037272ce1ac4ea8f file://LICENSE.OpenSSL;md5=c1eb3cee0a4dea27503c531267a69769" |
| 6 | |
| 7 | DEPENDS = " \ |
| 8 | glib-2.0-native \ |
| 9 | openssl \ |
| 10 | freerdp \ |
| 11 | gtk+3 \ |
| 12 | gdk-pixbuf \ |
| 13 | atk \ |
| 14 | libgcrypt \ |
| 15 | libsodium \ |
| 16 | libssh \ |
| 17 | vte \ |
| 18 | json-glib \ |
| 19 | libsoup-3.0 \ |
| 20 | libvncserver \ |
| 21 | libsecret \ |
| 22 | libxkbfile \ |
| 23 | " |
| 24 | |
| 25 | DEPENDS:append:libc-musl = " libexecinfo" |
| 26 | LDFLAGS:append:libc-musl = " -lexecinfo" |
| 27 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 28 | SRCREV = "4804f68f23045a38c3a7be46810fce14bac2fc3c" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 29 | SRC_URI = "git://gitlab.com/Remmina/Remmina;protocol=https;branch=master" |
| 30 | S = "${WORKDIR}/git" |
| 31 | |
| 32 | inherit cmake features_check mime mime-xdg gtk-icon-cache pkgconfig |
| 33 | REQUIRED_DISTRO_FEATURES = "x11" |
| 34 | |
| 35 | EXTRA_OECMAKE += "-DWITH_APPINDICATOR=OFF -DWITH_GETTEXT=OFF -DWITH_TRANSLATIONS=OFF -DHAVE_LIBAPPINDICATOR=OFF -DWITH_WEBKIT2GTK=OFF" |
| 36 | |
| 37 | PACKAGECONFIG[spice] = "-DWITH_SPICE=ON, -DWITH_SPICE=OFF, spice spice-protocol" |
| 38 | # Switch on gtk support in avahi recipe if you want to enable avahi support |
| 39 | PACKAGECONFIG[avahi] = "-DWITH_AVAHI=ON, -DWITH_AVAHI=OFF, avahi" |
| 40 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame] | 41 | do_configure:append() { |
| 42 | sed -i -e 's|${WORKDIR}|<WORKDIR>|g' ${B}/generated/buildflags.h |
| 43 | } |
| 44 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 45 | RDEPENDS:${PN} = "bash" |
| 46 | |
| 47 | FILES:${PN}+= " \ |
| 48 | ${datadir}/metainfo \ |
| 49 | ${datadir}/mime \ |
| 50 | " |