Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "the compiling PHP template engine" |
| 2 | SECTION = "console/network" |
| 3 | HOMEPAGE = "https://www.smarty.net/" |
| 4 | |
| 5 | LICENSE = "GPL-3.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=2c0f216b2120ffc367e20f2b56df51b3" |
| 7 | |
| 8 | DEPENDS += "php" |
| 9 | |
| 10 | SRC_URI = "git://github.com/smarty-php/smarty.git;protocol=https;branch=master" |
| 11 | |
| 12 | SRCREV = "c02e9e135ea719b91f457a0072748ded0e852e7d" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | do_install() { |
| 17 | install -d ${D}${datadir}/php/smarty3/libs/ |
| 18 | install -m 0644 ${S}/libs/*.php ${D}${datadir}/php/smarty3/libs/ |
| 19 | |
| 20 | install -d ${D}${datadir}/php/smarty3/libs/plugins |
| 21 | install -m 0644 ${S}/libs/plugins/*.php ${D}${datadir}/php/smarty3/libs/plugins/ |
| 22 | |
| 23 | install -d ${D}${datadir}/php/smarty3/libs/sysplugins |
| 24 | install -m 0644 ${S}/libs/sysplugins/*.php ${D}${datadir}/php/smarty3/libs/sysplugins/ |
| 25 | } |
| 26 | FILES:${PN} = "${datadir}/php/smarty3/" |