Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "Google Authentication Library" |
| 2 | HOMEPAGE = "https://github.com/googleapis/google-auth-library-python" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 5 | |
| 6 | inherit pypi setuptools3 |
| 7 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 8 | SRC_URI[sha256sum] = "d38bdf4fa1e7c5a35e574861bce55784fd08afadb4e48f99f284f1e487ce702d" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 9 | |
| 10 | RDEPENDS:${PN} += "\ |
| 11 | ${PYTHON_PN}-asyncio \ |
| 12 | ${PYTHON_PN}-datetime \ |
| 13 | ${PYTHON_PN}-io \ |
| 14 | ${PYTHON_PN}-json \ |
| 15 | ${PYTHON_PN}-logging \ |
| 16 | ${PYTHON_PN}-netclient \ |
| 17 | ${PYTHON_PN}-numbers \ |
| 18 | " |
| 19 | |
| 20 | RDEPENDS:${PN} += "\ |
| 21 | ${PYTHON_PN}-aiohttp \ |
| 22 | ${PYTHON_PN}-cachetools \ |
| 23 | ${PYTHON_PN}-pyasn1-modules \ |
| 24 | ${PYTHON_PN}-rsa \ |
| 25 | ${PYTHON_PN}-six \ |
| 26 | " |