Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | # |
| 8 | # Class to disable binconfig files instead of installing them |
| 9 | # |
| 10 | |
| 11 | # The list of scripts which should be disabled. |
| 12 | BINCONFIG ?= "" |
| 13 | |
| 14 | FILES:${PN}-dev += "${bindir}/*-config" |
| 15 | |
| 16 | do_install:append () { |
| 17 | for x in ${BINCONFIG}; do |
| 18 | # Make the disabled script emit invalid parameters for those configure |
| 19 | # scripts which call it without checking the return code. |
| 20 | echo "#!/bin/sh" > ${D}$x |
| 21 | echo "echo 'ERROR: $x should not be used, use an alternative such as pkg-config' >&2" >> ${D}$x |
| 22 | echo "echo '--should-not-have-used-$x'" >> ${D}$x |
| 23 | echo "exit 1" >> ${D}$x |
| 24 | chmod +x ${D}$x |
| 25 | done |
| 26 | } |
| 27 | |
| 28 | SYSROOT_PREPROCESS_FUNCS += "binconfig_disabled_sysroot_preprocess" |
| 29 | |
| 30 | binconfig_disabled_sysroot_preprocess () { |
| 31 | for x in ${BINCONFIG}; do |
| 32 | configname=`basename $x` |
| 33 | install -d ${SYSROOT_DESTDIR}${bindir_crossscripts} |
| 34 | install ${D}$x ${SYSROOT_DESTDIR}${bindir_crossscripts} |
| 35 | done |
| 36 | } |