Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | inherit python_pep517 python3native python3-dir setuptools3-base |
| 8 | |
| 9 | DEPENDS += "python3-hatchling-native" |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 10 | |
| 11 | # delete nested, empty directories from the python site-packages path. Make |
| 12 | # sure that we remove the native ones for target builds as well |
| 13 | hatchling_rm_emptydirs:class-target () { |
| 14 | find ${STAGING_LIBDIR}/${PYTHON_DIR}/site-packages/* -depth -type d -empty -delete |
| 15 | find ${STAGING_LIBDIR_NATIVE}/${PYTHON_DIR}/site-packages/* -depth -type d -empty -delete |
| 16 | } |
| 17 | |
| 18 | hatchling_rm_emptydirs:class-native () { |
| 19 | find ${STAGING_LIBDIR_NATIVE}/${PYTHON_DIR}/site-packages/* -depth -type d -empty -delete |
| 20 | } |
| 21 | |
| 22 | # Define a default empty version of hatchling_rm_emptydirs to appease bitbake |
| 23 | hatchling_rm_emptydirs () { |
| 24 | : |
| 25 | } |
| 26 | |
| 27 | do_prepare_recipe_sysroot[postfuncs] += " hatchling_rm_emptydirs" |