Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
2 | # Copyright OpenEmbedded Contributors | ||||
3 | # | ||||
4 | # SPDX-License-Identifier: MIT | ||||
5 | # | ||||
6 | |||||
7 | # This class ensures that the upstream version check only | ||||
8 | # accepts even minor versions (i.e. 3.0.x, 3.2.x, 3.4.x, etc.) | ||||
9 | # This scheme is used by Gnome and a number of other projects | ||||
10 | # to signify stable releases vs development releases. | ||||
11 | UPSTREAM_CHECK_REGEX = "[^\d\.](?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar" |