Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
2 | # Copyright OpenEmbedded Contributors | ||||
3 | # | ||||
4 | # SPDX-License-Identifier: MIT | ||||
5 | # | ||||
6 | |||||
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 7 | # This class removes libtool .la files after do_install |
8 | |||||
9 | REMOVE_LIBTOOL_LA ?= "1" | ||||
10 | |||||
11 | remove_libtool_la() { | ||||
12 | if [ "${REMOVE_LIBTOOL_LA}" != "0" ]; then | ||||
13 | find "${D}" -ignore_readdir_race -name "*.la" -delete | ||||
14 | fi | ||||
15 | } | ||||
16 | |||||
17 | do_install[postfuncs] += "remove_libtool_la" |