blob: 4bad0f86e14b7781f58f5f34ac27422e1032e570 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The GPL Ghostscript PostScript/PDF interpreter"
2DESCRIPTION = "Ghostscript is used for PostScript/PDF preview and printing. Usually as \
3a back-end to a program such as ghostview, it can display PostScript and PDF \
4documents in an X11 environment. \
5\
6Furthermore, it can render PostScript and PDF files as graphics to be printed \
7on non-PostScript printers. Supported printers include common \
8dot-matrix, inkjet and laser models. \
9"
10HOMEPAGE = "http://www.ghostscript.com"
11SECTION = "console/utils"
12
13LICENSE = "GPL-3.0-only"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=f98ffa763e50cded76f49bce73aade16"
15
Patrick Williams520786c2023-06-25 16:20:36 -050016DEPENDS = "tiff jpeg fontconfig cups libpng freetype zlib"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
18UPSTREAM_CHECK_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases"
19UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
20
Andrew Geissler517393d2023-01-13 08:55:19 -060021def gs_verdir(v):
22 return "".join(v.split("."))
23
24
Patrick Williams520786c2023-06-25 16:20:36 -050025SRC_URI = "https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${@gs_verdir("${PV}")}/${BPN}-${PV}.tar.gz \
26 file://ghostscript-9.16-Werror-return-type.patch \
27 file://avoid-host-contamination.patch \
Andrew Geissler5082cc72023-09-11 08:41:39 -040028 file://configure.ac-add-option-to-explicitly-disable-neon.patch \
Andrew Geissler220dafd2023-10-04 10:18:08 -050029 "
Andrew Geissler517393d2023-01-13 08:55:19 -060030
Andrew Geissler220dafd2023-10-04 10:18:08 -050031SRC_URI[sha256sum] = "e54062f166708d84ca82de9f8304a04344466080f936118b88082bd55ed6dc97"
Andrew Geissler517393d2023-01-13 08:55:19 -060032
Patrick Williams520786c2023-06-25 16:20:36 -050033PACKAGECONFIG ??= ""
34PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
35PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn"
36PACKAGECONFIG[libpaper] = "--with-libpaper,--without-libpaper,libpaper"
Andrew Geissler517393d2023-01-13 08:55:19 -060037PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${STAGING_LIBDIR}, \
Patrick Williams520786c2023-06-25 16:20:36 -050038 --without-x, virtual/libx11 libxext libxt"
Andrew Geissler517393d2023-01-13 08:55:19 -060039
Patrick Williams520786c2023-06-25 16:20:36 -050040EXTRA_OECONF = "--with-jbig2dec \
Andrew Geissler517393d2023-01-13 08:55:19 -060041 --with-fontpath=${datadir}/fonts \
Andrew Geissler517393d2023-01-13 08:55:19 -060042 CUPSCONFIG="${STAGING_BINDIR_CROSS}/cups-config" \
Patrick Williams520786c2023-06-25 16:20:36 -050043 PKGCONFIG=pkg-config \
Andrew Geissler517393d2023-01-13 08:55:19 -060044 "
45
46EXTRA_OECONF:append:mipsarcho32 = " --with-large_color_index=0"
47
Andrew Geissler5082cc72023-09-11 08:41:39 -040048EXTRA_OECONF:append:armv7a = "${@bb.utils.contains('TUNE_FEATURES','neon','',' --disable-neon',d)}"
49EXTRA_OECONF:append:armv7ve = "${@bb.utils.contains('TUNE_FEATURES','neon','',' --disable-neon',d)}"
50
Patrick Williams520786c2023-06-25 16:20:36 -050051# Uses autoconf but not automake, can't do out-of-tree
52inherit autotools-brokensep pkgconfig
Andrew Geissler517393d2023-01-13 08:55:19 -060053
Patrick Williams520786c2023-06-25 16:20:36 -050054# Prune the source tree of libraries that we're using our packaging of, so that
55# ghostscript can't link to them. Can't prune zlib as that's needed for the
56# native tools.
57prune_sources() {
58 rm -rf ${S}/jpeg/ ${S}/libpng/ ${S}/tiff/ ${S}/expat/ ${S}/freetype/ ${S}/cups/lib
Andrew Geissler517393d2023-01-13 08:55:19 -060059}
Patrick Williams520786c2023-06-25 16:20:36 -050060do_unpack[postfuncs] += "prune_sources"
Andrew Geissler517393d2023-01-13 08:55:19 -060061
62do_install:append () {
63 mkdir -p ${D}${datadir}/ghostscript/${PV}/
64 cp -r ${S}/Resource ${D}${datadir}/ghostscript/${PV}/
65 cp -r ${S}/iccprofiles ${D}${datadir}/ghostscript/${PV}/
66}
67
Andrew Geissler517393d2023-01-13 08:55:19 -060068# ghostscript does not supports "arc"
69COMPATIBLE_HOST = "^(?!arc).*"
70
71# some entries in NVD uses gpl_ghostscript
72CVE_PRODUCT = "ghostscript gpl_ghostscript"
Patrick Williams2a254922023-08-11 09:48:11 -050073
74CVE_STATUS[CVE-2023-38560] = "not-applicable-config: PCL isn't part of the Ghostscript release"