Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Protocol Buffers - structured data serialisation mechanism" |
| 2 | DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \ |
| 3 | serialization format. It includes libprotobuf-c, a pure C library that \ |
| 4 | implements protobuf encoding and decoding, and protoc-c, a code generator that \ |
| 5 | converts Protocol Buffer .proto files to C descriptor code, based on the \ |
| 6 | original protoc. protobuf-c formerly included an RPC implementation; that code \ |
| 7 | has been split out into the protobuf-c-rpc project." |
| 8 | HOMEPAGE = "https://github.com/protobuf-c/protobuf-c" |
| 9 | SECTION = "console/tools" |
| 10 | LICENSE = "BSD-2-Clause" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=cb901168715f4782a2b06c3ddaefa558" |
| 12 | |
| 13 | DEPENDS = "protobuf-native protobuf" |
| 14 | |
| 15 | SRCREV = "f20a3fa131c275a0e795d99a28f94b4dbbb5af26" |
| 16 | |
| 17 | SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \ |
| 18 | file://0001-avoid-race-condition.patch \ |
| 19 | " |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | inherit autotools pkgconfig |
| 24 | |
Andrew Geissler | c87764f | 2020-06-27 00:16:32 -0500 | [diff] [blame] | 25 | # After several fix attempts there is still a race between generating |
| 26 | # t.test-full.pb.h and compiling cxx_generate_packed_data.c despite |
| 27 | # BUILT_SOURCES and explicit dependencies. |
| 28 | PARALLEL_MAKE = "" |
| 29 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 30 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | FILES:${PN}-compiler = "${bindir}" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 33 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 34 | RDEPENDS:${PN}-compiler = "protobuf-compiler" |
| 35 | RDEPENDS:${PN}-dev += "${PN}-compiler" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 36 | |
| 37 | BBCLASSEXTEND = "native nativesdk" |