Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 1 | inherit esw deploy python3native |
| 2 | |
| 3 | DEPENDS += "dtc-native python3-dtc-native python3-pyyaml-native xilstandalone libxil xiltimer device-tree" |
| 4 | |
| 5 | do_configure_prepend() { |
| 6 | cd ${S} |
| 7 | nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} |
| 8 | } |
| 9 | |
| 10 | do_generate_eglist () { |
| 11 | cd ${S} |
| 12 | nativepython3 ${S}/scripts/example.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} |
| 13 | } |
| 14 | addtask generate_eglist before do_configure after do_prepare_recipe_sysroot |
| 15 | do_prepare_recipe_sysroot[rdeptask] = "do_unpack" |
| 16 | |
| 17 | do_install() { |
| 18 | install -d ${D}/${base_libdir}/firmware |
| 19 | install -m 0755 ${B}/*.elf ${D}/${base_libdir}/firmware |
| 20 | } |
| 21 | |
| 22 | do_deploy() { |
| 23 | install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/*.elf ${DEPLOYDIR}/ |
| 24 | } |
| 25 | addtask deploy before do_build after do_package |
| 26 | |
| 27 | FILES_${PN} = "${base_libdir}/firmware/*.elf" |