Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 1 | inherit esw python3native |
2 | |||||
3 | ESW_COMPONENT_SRC = "/ThirdParty/bsp/freertos10_xilinx/src/" | ||||
4 | ESW_COMPONENT_NAME = "libfreertos.a" | ||||
5 | |||||
6 | DEPENDS += "libxil xilstandalone xilmem dtc-native python3-pyyaml-native python3-dtc-native xiltimer" | ||||
7 | |||||
8 | do_configure_prepend() { | ||||
9 | # This script should also not rely on relative paths and such | ||||
10 | cd ${S} | ||||
11 | nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH} | ||||
12 | } |