Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "XFS Filesystem Utilities" |
| 2 | HOMEPAGE = "http://oss.sgi.com/projects/xfs" |
| 3 | SECTION = "base" |
| 4 | LICENSE = "GPL-2.0-only & LGPL-2.1-only" |
| 5 | LICENSE:libhandle = "LGPL-2.1-only" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSES/GPL-2.0;md5=e6a75371ba4d16749254a51215d13f97 \ |
| 7 | file://LICENSES/LGPL-2.1;md5=b370887980db5dd40659b50909238dbd" |
| 8 | DEPENDS = "util-linux util-linux-native" |
| 9 | SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsprogs/${BP}.tar.xz \ |
| 10 | file://remove_flags_from_build_flags.patch \ |
| 11 | file://0002-include-include-xfs-linux.h-after-sys-mman.h.patch \ |
| 12 | file://0001-support-usrmerge.patch \ |
| 13 | file://0004-configure-Use-AC_SYS_LARGERFILE-autoconf-macro.patch \ |
| 14 | file://0005-Replace-off64_t-stat64-with-off_t-stat.patch \ |
| 15 | " |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "05e8a137870db1d6182df72dda98ab7a7100deb376947e854b9d59c914c2c7bb" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | inherit autotools-brokensep pkgconfig |
| 18 | |
| 19 | PACKAGES =+ "${PN}-fsck ${PN}-mkfs ${PN}-repair libhandle" |
| 20 | |
| 21 | DEPENDS += "util-linux libinih liburcu" |
| 22 | |
| 23 | RDEPENDS:${PN} = "${PN}-fsck ${PN}-mkfs ${PN}-repair" |
| 24 | |
| 25 | FILES:${PN}-fsck = "${base_sbindir}/fsck.xfs" |
| 26 | FILES:${PN}-mkfs = "${base_sbindir}/mkfs.xfs" |
| 27 | FILES:${PN}-repair = "${base_sbindir}/xfs_repair" |
| 28 | |
| 29 | FILES:libhandle = "${base_libdir}/libhandle${SOLIBS}" |
| 30 | |
| 31 | EXTRA_OECONF = "--enable-gettext=no \ |
| 32 | --enable-scrub=no \ |
| 33 | INSTALL_USER=root \ |
| 34 | INSTALL_GROUP=root \ |
| 35 | ac_cv_header_aio_h=yes \ |
| 36 | ac_cv_lib_rt_lio_listio=yes \ |
| 37 | OPTIMIZER='${SELECTED_OPTIMIZATION}' \ |
| 38 | " |
| 39 | |
| 40 | DISABLE_STATIC = "" |
| 41 | EXTRA_AUTORECONF += "-I ${S}/m4 --exclude=autoheader" |
| 42 | |
| 43 | PACKAGECONFIG ??= "blkid" |
| 44 | |
| 45 | PACKAGECONFIG[blkid] = "--enable-blkid=yes,--enable-blkid=no,util-linux" |
| 46 | |
| 47 | export DEBUG="-DNDEBUG" |
| 48 | export BUILD_VERBOSE="1" |
| 49 | export tagname="CC" |
| 50 | |
| 51 | EXTRA_OEMAKE = "DIST_ROOT='${D}'" |
| 52 | |
| 53 | do_configure () { |
| 54 | export BUILD_CC="${BUILD_CC} ${BUILD_CFLAGS}" |
| 55 | # Prevent Makefile from calling configure without arguments, |
| 56 | # when do_configure gets called for a second time. |
| 57 | rm -f ${B}/include/builddefs ${B}/include/platform_defs.h ${B}/configure |
| 58 | # Recreate configure script. |
| 59 | oe_runmake configure |
| 60 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S} |
| 61 | install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S} |
| 62 | oe_runconf |
| 63 | } |
| 64 | |
| 65 | do_install:append() { |
| 66 | oe_runmake 'DESTDIR=${D}' install-dev |
| 67 | rm ${D}${libdir}/*.la |
| 68 | rmdir --ignore-fail-on-non-empty ${D}${libdir} |
| 69 | |
| 70 | if [ ${libdir} != ${base_libdir} ];then |
| 71 | ln -sf -r ${D}${libdir}/libhandle.a ${D}${base_libdir}/libhandle.a |
| 72 | ln -sf -r ${D}${base_libdir}/libhandle.so ${D}${libdir}/libhandle.so |
| 73 | fi |
| 74 | } |