blob: 9bf38092443dc4a3a7f1108e7c2c4f3ec0d05edd [file] [log] [blame]
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06001DESCRIPTION = "A file format designed for highly efficient deltas while maintaining good compression"
2AUTHOR = "Jonathan Dieter"
3
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=daf6e68539f564601a5a5869c31e5242"
6
7SRC_URI = "git://github.com/zchunk/zchunk.git;protocol=https;branch=main"
8
Patrick Williamse760df82023-05-26 11:10:49 -05009SRCREV = "b462b1587f7d3aa782689430e83e96c737748f33"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060010S = "${WORKDIR}/git"
11
12DEPENDS = "zstd"
13DEPENDS:append:libc-musl = " argp-standalone"
14
15inherit meson pkgconfig lib_package
16
17PACKAGECONFIG ??= "openssl zckdl"
18
19# zckdl gets packaged into zchunk-bin
20PACKAGECONFIG[zckdl] = "-Dwith-curl=enabled,-Dwith-curl=disabled,curl"
21# Use OpenSSL primitives for SHA
22PACKAGECONFIG[openssl] = "-Dwith-openssl=enabled,-Dwith-openssl=disabled,openssl"
23
24BBCLASSEXTEND = "native nativesdk"