blob: f414a4b1dcca984777a9af25d328e14879c1551f [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "nl80211 based CLI configuration utility for wireless devices"
2DESCRIPTION = "iw is a new nl80211 based CLI configuration utility for \
3wireless devices. It supports almost all new drivers that have been added \
4to the kernel recently. "
5HOMEPAGE = "http://wireless.kernel.org/en/users/Documentation/iw"
6SECTION = "base"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=878618a5c4af25e9b93ef0be1a93f774"
9
10DEPENDS = "libnl"
11
12SRC_URI = "http://www.kernel.org/pub/software/network/iw/${BP}.tar.gz \
13 file://0001-iw-version.sh-don-t-use-git-describe-for-versioning.patch \
14 file://separate-objdir.patch \
Andrew Geissler99467da2019-02-25 18:54:23 -060015 file://0001-connect-fix-parsing-of-WEP-keys.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040016"
17
18SRC_URI[md5sum] = "2067516ca9940fdb8c091ee3250da374"
19SRC_URI[sha256sum] = "a0c3aad6ff52234d03a2522ba2eba570e36abb3e60dc29bf0b1ce88dd725d6d4"
20
21inherit pkgconfig
22
23EXTRA_OEMAKE = "\
24 -f '${S}/Makefile' \
25 \
26 'PREFIX=${prefix}' \
27 'SBINDIR=${sbindir}' \
28 'MANDIR=${mandir}' \
29"
30B = "${WORKDIR}/build"
31
32do_install() {
33 oe_runmake 'DESTDIR=${D}' install
34}