Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
2 | # Copyright OpenEmbedded Contributors | ||||
3 | # | ||||
4 | # SPDX-License-Identifier: MIT | ||||
5 | # | ||||
6 | |||||
7 | inherit python_pyo3 setuptools3 | ||||
8 | |||||
9 | DEPENDS += "python3-setuptools-rust-native" | ||||
10 | |||||
11 | python_setuptools3_rust_do_configure() { | ||||
12 | python_pyo3_do_configure | ||||
13 | cargo_common_do_configure | ||||
14 | setuptools3_do_configure | ||||
15 | } | ||||
16 | |||||
17 | EXPORT_FUNCTIONS do_configure |