Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 1 | inherit features_check |
| 2 | REQUIRED_DISTRO_FEATURES = "ptest" |
| 3 | |
| 4 | require recipes-core/images/core-image-minimal.bb |
| 5 | require conf/include/ptest-packagelists-meta-multimedia.inc |
| 6 | |
| 7 | SUMMARY = "meta-multimedia ptest test image" |
| 8 | |
| 9 | DESCRIPTION += "Also including the ${MCNAME} ptest package." |
| 10 | HOMEPAGE = "https://www.openembedded.org/" |
| 11 | |
| 12 | PTESTS_META_MULTIMEDIA = "${PTESTS_SLOW_META_MULTIMEDIA} ${PTESTS_FAST_META_MULTIMEDIA} ${PTESTS_PROBLEMS_META_MULTIMEDIA}" |
| 13 | |
| 14 | IMAGE_INSTALL:append = " ${MCNAME}-ptest openssh" |
| 15 | |
| 16 | BBCLASSEXTEND = "${@' '.join(['mcextend:'+x for x in d.getVar('PTESTS_META_MULTIMEDIA').split()])}" |
| 17 | |
| 18 | # The image can be sufficiently large (~1.8GB) that we need to be careful that it fits in a live |
| 19 | # image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the |
| 20 | # box) and explicitly add up to 1500MB. |
| 21 | IMAGE_OVERHEAD_FACTOR = "1.0" |
| 22 | IMAGE_ROOTFS_EXTRA_SPACE = "324288" |
| 23 | # If a particular ptest needs more space, it can be customized: |
| 24 | #IMAGE_ROOTFS_EXTRA_SPACE:virtclass-mcextend-<pn> = "1024288" |
| 25 | |
| 26 | # ptests need more memory than standard to avoid the OOM killer |
| 27 | QB_MEM = "-m 1024" |
| 28 | # If a particular ptest needs more memroy, it can be customized: |
| 29 | #QB_MEM:virtclass-mcextend-<pn> = "-m 4096" |
| 30 | |
| 31 | TEST_SUITES = "ping ssh parselogs ptest" |
| 32 | |
| 33 | # Sadly at the moment the full set of ptests is not robust enough and sporadically fails in random places |
| 34 | PTEST_EXPECT_FAILURE = "1" |
| 35 | |
| 36 | python () { |
| 37 | if not d.getVar("MCNAME"): |
| 38 | raise bb.parse.SkipRecipe("No class extension set") |
| 39 | } |
| 40 | |