Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Gnuplot is a portable command-line driven graphing utility" |
| 2 | DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \ |
| 3 | (text or binary) and function plotting utility." |
| 4 | HOMEPAGE = "http://www.gnuplot.info/" |
| 5 | SECTION = "console/scientific" |
| 6 | LICENSE = "gnuplot" |
| 7 | LIC_FILES_CHKSUM = "file://Copyright;md5=243a186fc2fd3b992125d60d5b1bab8f" |
| 8 | DEPENDS = "${BPN}-native virtual/libx11 gd readline" |
| 9 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame] | 10 | inherit autotools features_check pkgconfig |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 11 | # depends on virtual/libx11 |
| 12 | REQUIRED_DISTRO_FEATURES = "x11" |
| 13 | |
| 14 | SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${PV}/${BP}.tar.gz;name=archive \ |
| 15 | http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz;name=qtplot \ |
| 16 | file://gnuplot.desktop \ |
| 17 | file://gnuplot.png \ |
| 18 | " |
| 19 | SRC_URI:append:class-target = " \ |
| 20 | file://0002-do-not-build-demos.patch \ |
| 21 | file://0003-Use-native-tools-to-build-docs.patch \ |
| 22 | file://0004-Add-configure-option-to-find-qt5-native-tools.patch \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI[archive.sha256sum] = "51f89bbab90f96d3543f95235368d188eb1e26eda296912256abcd3535bd4d84" |
| 26 | SRC_URI[qtplot.sha256sum] = "6df317183ff62cc82f3dcf88207a267cd6478cb5147f55d7530c94f1ad5f4132" |
| 27 | |
| 28 | # for building docs (they deserve it) we need *doc2* tools native |
| 29 | BBCLASSEXTEND = "native" |
| 30 | DEPENDS:class-native = "readline-native" |
| 31 | PACKAGECONFIG:class-native = "" |
| 32 | |
| 33 | SRC_URI:append:class-native = " file://0001-reduce-build-to-conversion-tools-for-native-build.patch" |
| 34 | |
| 35 | do_install:class-native() { |
| 36 | install -d ${D}${bindir} |
| 37 | install ${B}/docs/*doc* ${D}${bindir} |
| 38 | rm ${D}${bindir}/*.o |
| 39 | } |
| 40 | |
| 41 | PACKAGECONFIG ??= "cairo" |
| 42 | PACKAGECONFIG[cairo] = "--with-cairo,--without-cairo,cairo pango" |
| 43 | PACKAGECONFIG[lua] = "--with-lua,--without-lua,lua" |
| 44 | PACKAGECONFIG[qt5] = "--with-qt --with-qt5nativesysroot=${STAGING_DIR_NATIVE},--without-qt,qtbase-native qtbase qtsvg qttools-native" |
| 45 | |
| 46 | EXTRA_OECONF = " \ |
| 47 | --with-readline=${STAGING_LIBDIR}/.. \ |
Patrick Williams | 5877637 | 2022-04-13 09:07:35 -0500 | [diff] [blame] | 48 | --disable-wxwidgets \ |
| 49 | --without-libcerf \ |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 50 | " |
| 51 | |
| 52 | do_compile:prepend() { |
| 53 | install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/ |
| 54 | } |
| 55 | |
| 56 | do_install:append:class-target() { |
| 57 | install -d ${D}${datadir}/applications/ |
| 58 | install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/ |
| 59 | install -d ${D}${datadir}/pixmaps/ |
| 60 | install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/ |
| 61 | } |
| 62 | |
| 63 | PACKAGES =+ "${PN}-x11" |
| 64 | |
| 65 | RPROVIDES:${PN}-dbg += "${PN}-x11-dbg" |
| 66 | |
| 67 | DESCRIPTION:${PN}-x11 = "X11 display terminal for Gnuplot." |
| 68 | SECTION:${PN}-x11 = "x11/scientific" |
| 69 | FILES:${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps ${libdir}/X11 " |
| 70 | |
| 71 | FILES:${PN} += "${datadir}/texmf" |