Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Control and monitor storage systems using S.M.A.R.T" |
| 2 | DESCRIPTION = "\ |
| 3 | The smartmontools package contains two utility programs (smartctl \ |
| 4 | and smartd) to control and monitor storage systems using the Self-\ |
| 5 | Monitoring, Analysis and Reporting Technology System (SMART) built \ |
| 6 | into most modern ATA and SCSI hard disks. In many cases, these \ |
| 7 | utilities will provide advanced warning of disk degradation and failure." |
| 8 | |
| 9 | HOMEPAGE = "http://smartmontools.sourceforge.net/" |
| 10 | SECTION = "console/utils" |
| 11 | |
| 12 | LICENSE = "GPL-2.0-only" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 14 | |
| 15 | SRC_URI = "${SOURCEFORGE_MIRROR}/smartmontools/smartmontools-${PV}.tar.gz \ |
| 16 | file://initd.smartd \ |
| 17 | file://smartmontools.default \ |
| 18 | file://smartd.service \ |
| 19 | file://0001-configure.ac-Define-SOURCE_DATE_EPOCH-in-CPPFLAGS.patch \ |
| 20 | " |
| 21 | |
| 22 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'libcap-ng selinux', d)}" |
| 23 | PACKAGECONFIG[libcap-ng] = "--with-libcap-ng=yes,--with-libcap-ng=no,libcap-ng" |
| 24 | PACKAGECONFIG[selinux] = "--with-selinux=yes,--with-selinux=no,libselinux" |
| 25 | |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 26 | SRC_URI[sha256sum] = "e9a61f641ff96ca95319edfb17948cd297d0cd3342736b2c49c99d4716fb993d" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 27 | |
| 28 | inherit autotools update-rc.d systemd |
| 29 | |
| 30 | SYSTEMD_SERVICE:${PN} = "smartd.service" |
| 31 | SYSTEMD_AUTO_ENABLE = "disable" |
| 32 | |
| 33 | do_install:append () { |
| 34 | #install the init.d/smartd |
| 35 | install -d ${D}${sysconfdir}/init.d |
| 36 | install -p -m 0755 ${WORKDIR}/initd.smartd ${D}${sysconfdir}/init.d/smartd |
| 37 | install -d ${D}${sysconfdir}/default |
| 38 | install -p -m 0644 ${WORKDIR}/smartmontools.default ${D}${sysconfdir}/default/smartmontools |
| 39 | |
| 40 | #install systemd service file |
| 41 | install -d ${D}${systemd_unitdir}/system |
| 42 | install -m 0644 ${WORKDIR}/smartd.service ${D}${systemd_unitdir}/system |
| 43 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ |
| 44 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ |
| 45 | -e 's,@SBINDIR@,${sbindir},g' \ |
| 46 | ${D}${systemd_unitdir}/system/smartd.service |
| 47 | } |
| 48 | |
| 49 | INITSCRIPT_NAME = "smartd" |
| 50 | INITSCRIPT_PARAMS = "start 60 2 3 4 5 . stop 60 0 1 6 ." |
| 51 | |
| 52 | RRECOMMENDS:${PN} += "s-nail" |