blob: c0143718347684042f149faf1334af32bc9b783e [file] [log] [blame]
Patrick Williams73bd93f2024-02-20 08:07:48 -06001DESCRIPTION = "DNS toolkit for Python"
2HOMEPAGE = "http://www.dnspython.org/"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34"
5
Patrick Williams39653562024-03-01 08:54:02 -06006SRC_URI[sha256sum] = "233f871ff384d84c33b2eaf4358ffe7f8927eae3b257ad8467f9bdba7e7ac6bc"
Patrick Williams73bd93f2024-02-20 08:07:48 -06007
8inherit pypi python_hatchling ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 python3-pytest \
16 python3-unittest-automake-output \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24DEPENDS += "\
25 python3-wheel-native \
26 python3-setuptools-scm-native \
27"
28
29RDEPENDS:${PN} += " \
30 python3-crypt \
31 python3-io \
32 python3-math \
33 python3-netclient \
34 python3-numbers \
35 python3-threading \
36"