Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 1 | DESCRIPTION = "DNS toolkit for Python" |
| 2 | HOMEPAGE = "http://www.dnspython.org/" |
| 3 | LICENSE = "ISC" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5af50906b5929837f667dfe31052bd34" |
| 5 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 6 | SRC_URI[sha256sum] = "233f871ff384d84c33b2eaf4358ffe7f8927eae3b257ad8467f9bdba7e7ac6bc" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 7 | |
| 8 | inherit pypi python_hatchling ptest |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN}-ptest += " \ |
| 15 | python3-pytest \ |
| 16 | python3-unittest-automake-output \ |
| 17 | " |
| 18 | |
| 19 | do_install_ptest() { |
| 20 | install -d ${D}${PTEST_PATH}/tests |
| 21 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 22 | } |
| 23 | |
| 24 | DEPENDS += "\ |
| 25 | python3-wheel-native \ |
| 26 | python3-setuptools-scm-native \ |
| 27 | " |
| 28 | |
| 29 | RDEPENDS:${PN} += " \ |
| 30 | python3-crypt \ |
| 31 | python3-io \ |
| 32 | python3-math \ |
| 33 | python3-netclient \ |
| 34 | python3-numbers \ |
| 35 | python3-threading \ |
| 36 | " |