blob: 3c5be47806575c65fd444274dd8792c6ef94e365 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001DESCRIPTION = "Interval arithmetic for Python"
2HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals"
3SECTION = "devel/python"
4
5LICENSE = "LGPL-3.0-only"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05f1e16a8e59ce3e9a979e881816c2ab"
7
8PYPI_PACKAGE := "python-intervals"
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14inherit pypi setuptools3 ptest
15
16RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060017 python3-pytest \
18 python3-unittest-automake-output \
Andrew Geissler9aee5002022-03-30 16:27:02 +000019"
20
21do_install_ptest() {
22 cp -f ${S}/test_intervals.py ${D}${PTEST_PATH}
23 cp -f ${S}/README.md ${D}${PTEST_PATH}
24}
25
26SRC_URI[sha256sum] = "0d26746eaed0be78a61dd289bb7a10721b08770bb3e807614835f490d514f2a5"
27
28BBCLASSEXTEND = "native"