Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | DESCRIPTION = "Interval arithmetic for Python" |
| 2 | HOMEPAGE = "https://github.com/AlexandreDecan/python-intervals" |
| 3 | SECTION = "devel/python" |
| 4 | |
| 5 | LICENSE = "LGPL-3.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=05f1e16a8e59ce3e9a979e881816c2ab" |
| 7 | |
| 8 | PYPI_PACKAGE := "python-intervals" |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | inherit pypi setuptools3 ptest |
| 15 | |
| 16 | RDEPENDS:${PN}-ptest += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 17 | python3-pytest \ |
| 18 | python3-unittest-automake-output \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 19 | " |
| 20 | |
| 21 | do_install_ptest() { |
| 22 | cp -f ${S}/test_intervals.py ${D}${PTEST_PATH} |
| 23 | cp -f ${S}/README.md ${D}${PTEST_PATH} |
| 24 | } |
| 25 | |
| 26 | SRC_URI[sha256sum] = "0d26746eaed0be78a61dd289bb7a10721b08770bb3e807614835f490d514f2a5" |
| 27 | |
| 28 | BBCLASSEXTEND = "native" |