George Hung | 5f2142e | 2020-06-19 19:45:43 +0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Quanta GBS System Initialization Service" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Quanta GBS System Init" |
| 3 | PR = "r1" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit systemd |
| 8 | |
| 9 | DEPENDS += "systemd" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 10 | RDEPENDS:${PN} += "bash" |
| 11 | RDEPENDS:${PN} += "i2c-tools" |
| 12 | RDEPENDS:${PN} += "jq" |
| 13 | RDEPENDS:${PN} += "libsystemd" |
George Hung | 5f2142e | 2020-06-19 19:45:43 +0800 | [diff] [blame] | 14 | |
| 15 | SRC_URI = "file://gbs-sysinit.sh \ |
| 16 | file://gbs-gpio-common.sh \ |
| 17 | file://gbs-sysinit.service \ |
| 18 | " |
| 19 | |
| 20 | do_install () { |
| 21 | install -d ${D}${bindir} |
| 22 | install -m 0755 ${WORKDIR}/gbs-sysinit.sh ${D}${bindir}/ |
| 23 | |
| 24 | install -d ${D}${libexecdir} |
| 25 | install -m 0755 ${WORKDIR}/gbs-gpio-common.sh ${D}${libexecdir}/ |
| 26 | |
| 27 | install -d ${D}${systemd_system_unitdir} |
| 28 | install -m 0644 ${WORKDIR}/gbs-sysinit.service ${D}${systemd_system_unitdir} |
| 29 | } |
| 30 | |
| 31 | SYSTEMD_PACKAGES = "${PN}" |
Brandon Kim | 1e42709 | 2021-08-10 15:46:03 -0700 | [diff] [blame] | 32 | SYSTEMD_SERVICE:${PN} = "gbs-sysinit.service" |