blob: d3d4e7d50aa032ae8fbc3943a1b02f1bfdd7bb33 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Linux kernel Bluetooth firmware files from Raspbian distribution"
2DESCRIPTION = "Updated Bluetooth firmware files for RaspberryPi hardware. \
3RPi-Distro obtains these directly from Cypress; they are not submitted \
4to linux-firmware for general use."
5HOMEPAGE = "https://github.com/RPi-Distro/bluez-firmware"
6SECTION = "kernel"
7
8# Upstream has provided[^1] licensing information in the Debian
9# copyright file. The wording of the Cypress license subsequently
10# changed in linux-firmware.
11#
12# Rather than make assumptions about what's supposed to be what, we'll
13# use the license implied by the source of these files, named to avoid
14# conflicts with linux-firmware.
15#
16# [^1]: https://github.com/RPi-Distro/bluez-firmware/issues/1
17LICENSE = "Firmware-cypress-rpidistro"
18LIC_FILES_CHKSUM = "\
William A. Kennington IIIa99e9b62021-06-02 12:47:56 -070019 file://LICENCE.cypress-rpidistro;md5=c5d12ae0b24ef7177902a8e288751a4e \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020"
21
22# These are not common licenses, set NO_GENERIC_LICENSE for them
23# so that the license files will be copied from fetched source
24NO_GENERIC_LICENSE[Firmware-cypress-rpidistro] = "LICENCE.cypress-rpidistro"
25
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050026SRC_URI = " \
27 git://github.com/RPi-Distro/bluez-firmware;branch=master;protocol=https \
Patrick Williamsdb4c27e2022-08-05 08:10:29 -050028"
Andrew Geissler220dafd2023-10-04 10:18:08 -050029SRCREV = "9556b08ace2a1735127894642cc8ea6529c04c90"
30PV = "1.2-4+rpt10"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031
32S = "${WORKDIR}/git"
33
34inherit allarch
35
36CLEANBROKEN = "1"
37
38do_extract_lic() {
39 # Extract the license from the Debian copyright file
40 sed -e '1,23d' ${S}/debian/copyright > ${S}/LICENCE.cypress-rpidistro
41}
42# Must be before both do_install and do_populate_lic. Putting it before
43# their common ancestor works; other approaches do not.
Patrick Williams03907ee2022-05-01 06:28:52 -050044addtask extract_lic after do_unpack before do_patch do_create_spdx
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080045
46do_compile() {
47 :
48}
49
50do_install() {
51 install -d ${D}${nonarch_base_libdir}/firmware/brcm
52
53 cp LICENCE.cypress-rpidistro ${D}${nonarch_base_libdir}/firmware
54 install -m 0644 broadcom/BCM434*.hcd ${D}${nonarch_base_libdir}/firmware/brcm/
55}
56
57PACKAGES = "\
58 ${PN}-cypress-license \
59 ${PN}-bcm43430a1-hcd \
William A. Kennington IIIa99e9b62021-06-02 12:47:56 -070060 ${PN}-bcm43430b0-hcd \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080061 ${PN}-bcm4345c0-hcd \
William A. Kennington IIIa99e9b62021-06-02 12:47:56 -070062 ${PN}-bcm4345c5-hcd \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080063"
64
Patrick Williams213cb262021-08-07 19:21:33 -050065LICENSE:${PN}-bcm43430a1-hcd = "Firmware-cypress-rpidistro"
66LICENSE:${PN}-bcm43430b0-hcd = "Firmware-cypress-rpidistro"
67LICENSE:${PN}-bcm4345c0-hcd = "Firmware-cypress-rpidistro"
68LICENSE:${PN}-bcm4345c5-hcd = "Firmware-cypress-rpidistro"
69LICENSE:${PN}-cypress-license = "Firmware-cypress-rpidistro"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080070
Patrick Williams213cb262021-08-07 19:21:33 -050071FILES:${PN}-cypress-license = "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080072 ${nonarch_base_libdir}/firmware/LICENCE.cypress-rpidistro \
73"
Patrick Williams213cb262021-08-07 19:21:33 -050074FILES:${PN}-bcm43430a1-hcd = "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080075 ${nonarch_base_libdir}/firmware/brcm/BCM43430A1.hcd \
76"
Patrick Williams213cb262021-08-07 19:21:33 -050077FILES:${PN}-bcm43430b0-hcd = "\
William A. Kennington IIIa99e9b62021-06-02 12:47:56 -070078 ${nonarch_base_libdir}/firmware/brcm/BCM43430B0.hcd \
79"
Patrick Williams213cb262021-08-07 19:21:33 -050080FILES:${PN}-bcm4345c0-hcd = "\
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080081 ${nonarch_base_libdir}/firmware/brcm/BCM4345C0.hcd \
82"
Patrick Williams213cb262021-08-07 19:21:33 -050083FILES:${PN}-bcm4345c5-hcd = "\
William A. Kennington IIIa99e9b62021-06-02 12:47:56 -070084 ${nonarch_base_libdir}/firmware/brcm/BCM4345C5.hcd \
85"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080086
Patrick Williams213cb262021-08-07 19:21:33 -050087RDEPENDS:${PN}-bcm43430a1-hcd += "${PN}-cypress-license"
88RDEPENDS:${PN}-bcm43430b0-hcd += "${PN}-cypress-license"
89RDEPENDS:${PN}-bcm4345c0-hcd += "${PN}-cypress-license"
90RDEPENDS:${PN}-bcm4345c5-hcd += "${PN}-cypress-license"
91RCONFLICTS:${PN}-bcm43430a1-hcd = "linux-firmware-bcm43430a1-hcd"
92RREPLACES:${PN}-bcm43430a1-hcd = "linux-firmware-bcm43430a1-hcd"
93RCONFLICTS:${PN}-bcm43430b0-hcd = "linux-firmware-bcm43430b0-hcd"
94RREPLACES:${PN}-bcm43430b0-hcd = "linux-firmware-bcm43430b0-hcd"
95RCONFLICTS:${PN}-bcm43435c0-hcd = "linux-firmware-bcm4345c0-hcd"
96RREPLACES:${PN}-bcm43435c0-hcd = "linux-firmware-bcm4345c0-hcd"
97RCONFLICTS:${PN}-bcm43435c5-hcd = "linux-firmware-bcm4345c5-hcd"
98RREPLACES:${PN}-bcm43435c5-hcd = "linux-firmware-bcm4345c5-hcd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080099
100# Firmware files are generally not run on the CPU, so they can be
101# allarch despite being architecture specific
102INSANE_SKIP = "arch"