Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | def gettext_dependencies(d): |
| 8 | if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'): |
| 9 | return "" |
| 10 | if d.getVar('USE_NLS') == 'no': |
| 11 | return "gettext-minimal-native" |
| 12 | return "gettext-native" |
| 13 | |
| 14 | def gettext_oeconf(d): |
| 15 | if d.getVar('USE_NLS') == 'no': |
| 16 | return '--disable-nls' |
| 17 | # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set |
| 18 | if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'): |
| 19 | return '--disable-nls' |
| 20 | return "--enable-nls" |
| 21 | |
| 22 | BASEDEPENDS:append = " ${@gettext_dependencies(d)}" |
| 23 | EXTRA_OECONF:append = " ${@gettext_oeconf(d)}" |
| 24 | |
| 25 | # Without this, msgfmt from gettext-native will not find ITS files |
| 26 | # provided by target recipes (for example, polkit.its). |
| 27 | GETTEXTDATADIRS:append:class-target = ":${STAGING_DATADIR}/gettext" |
| 28 | export GETTEXTDATADIRS |