Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | # Gather existing and candidate postinst intercepts from BBPATH |
| 8 | POSTINST_INTERCEPTS_DIR ?= "${COREBASE}/scripts/postinst-intercepts" |
| 9 | POSTINST_INTERCEPTS_PATHS ?= "${@':'.join('%s/postinst-intercepts' % p for p in '${BBPATH}'.split(':'))}:${POSTINST_INTERCEPTS_DIR}" |
| 10 | |
| 11 | python find_intercepts() { |
| 12 | intercepts = {} |
| 13 | search_paths = [] |
| 14 | paths = d.getVar('POSTINST_INTERCEPTS_PATHS').split(':') |
| 15 | overrides = (':' + d.getVar('FILESOVERRIDES')).split(':') + [''] |
| 16 | search_paths = [os.path.join(p, op) for p in paths for op in overrides] |
| 17 | searched = oe.path.which_wild('*', ':'.join(search_paths), candidates=True) |
| 18 | files, chksums = [], [] |
| 19 | for pathname, candidates in searched: |
| 20 | if os.path.isfile(pathname): |
| 21 | files.append(pathname) |
| 22 | chksums.append('%s:True' % pathname) |
| 23 | chksums.extend('%s:False' % c for c in candidates[:-1]) |
| 24 | |
| 25 | d.setVar('POSTINST_INTERCEPT_CHECKSUMS', ' '.join(chksums)) |
| 26 | d.setVar('POSTINST_INTERCEPTS', ' '.join(files)) |
| 27 | } |
| 28 | find_intercepts[eventmask] += "bb.event.RecipePreFinalise" |
| 29 | addhandler find_intercepts |